summaryrefslogtreecommitdiff
path: root/CHANGES
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2012-02-28 11:21:07 -0500
committerMike Bayer <mike_mp@zzzcomputing.com>2012-02-28 11:21:07 -0500
commit53b9cccf73a7655191186fcc9b721f7a448255c0 (patch)
tree992d7e2d0647f52e8ed2766411e54b99d9304c70 /CHANGES
parent11549d1f4c1889a1b72a1391e6ee41d67b47cdbf (diff)
downloadalembic-53b9cccf73a7655191186fcc9b721f7a448255c0.tar.gz
- [bug] implement 'tablename' parameter on
drop_index() as this is needed by some backends. - [feature] Added execution_options parameter to op.execute(), will call execution_options() on the Connection before executing. The immediate use case here is to allow access to the new no_parameters option in SQLAlchemy 0.7.6, which allows some DBAPIs (psycopg2, MySQLdb) to allow percent signs straight through without escaping, thus providing cross-compatible operation with DBAPI execution and static script generation.
Diffstat (limited to 'CHANGES')
-rw-r--r--CHANGES19
1 files changed, 18 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index e1cd2bf..6efa997 100644
--- a/CHANGES
+++ b/CHANGES
@@ -2,7 +2,24 @@
=====
- [feature] Informative error message when op.XYZ
directives are invoked at module import time.
-
+
+- [bug] implement 'tablename' parameter on
+ drop_index() as this is needed by some
+ backends.
+
+- [feature] Added execution_options parameter
+ to op.execute(), will call execution_options()
+ on the Connection before executing.
+
+ The immediate use case here is to allow
+ access to the new no_parameters option
+ in SQLAlchemy 0.7.6, which allows
+ some DBAPIs (psycopg2, MySQLdb) to allow
+ percent signs straight through without
+ escaping, thus providing cross-compatible
+ operation with DBAPI execution and
+ static script generation.
+
- [bug] setup.py won't install argparse if on
Python 2.7/3.2