summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorCaselIT <cfederico87@gmail.com>2022-09-11 22:38:46 +0200
committerCaselIT <cfederico87@gmail.com>2022-09-12 21:00:52 +0200
commit0e83fddb6c110bf1658564c248ffad9163a365fa (patch)
tree9b61207cd621fb526cda1daa55eaf94bd50aeb25 /pyproject.toml
parent747ec301529cf2a08d56d3596aedbf54a93b8742 (diff)
downloadalembic-0e83fddb6c110bf1658564c248ffad9163a365fa.tar.gz
Improve typing
Change-Id: I9fc86c4a92e1b76d19c9e891ff08ce8a46ad4e35
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 2a8de06..f66269a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -17,6 +17,17 @@ show_error_codes = true
[[tool.mypy.overrides]]
module = [
+ 'alembic.operations.ops',
+ 'alembic.op',
+ 'alembic.context',
+ 'alembic.autogenerate.api',
+ 'alembic.runtime.*',
+]
+
+disallow_incomplete_defs = true
+
+[[tool.mypy.overrides]]
+module = [
'mako.*',
'sqlalchemy.testing.*'
]