summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorCaselIT <cfederico87@gmail.com>2020-10-19 23:23:08 +0200
committerMike Bayer <mike_mp@zzzcomputing.com>2021-01-11 23:41:43 -0500
commit365283aac593698fa483b54554f9443db3fe4933 (patch)
tree08cfa15232ef2e63b444d506f5750a704f97901e /setup.cfg
parentebc1ea35b127bd56c48dcae43d226471fd6bf6c0 (diff)
downloadalembic-365283aac593698fa483b54554f9443db3fe4933.tar.gz
Accommodate SQLAlchemy 1.4/2.0
To accommodate SQLAlchemy 1.4 and 2.0, the migration model now no longer assumes that the SQLAlchemy Connection will autocommit an individual operation. This essentially means that for databases that use non-transactional DDL (pysqlite current driver behavior, MySQL), there is still a BEGIN/COMMIT block that will surround each individual migration. Databases that support transactional DDL should continue to have the same flow, either per migration or per-entire run, depending on the value of the :paramref:`.Environment.configure.transaction_per_migration` flag. Compatibility is established such that the entire library should not generate any SQLAlchemy 2.0 deprecation warnings and SQLALCHEMY_WARN_20 is part of conftest.py. (one warning remains for the moment that needs to be resolved on the SQLAlchemy side) The test suite requires SQLAlchemy 1.4.0b2 for testing 1.4; 1.4.0b1 won't work. Test suite / setup also being modernized, as we are at SQLAlchemy 1.3 we can now remove the majority of the testing suite plugin. Change-Id: If55b1ea3c12ead66405ab3fadc76d15d89dabb90
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg70
1 files changed, 67 insertions, 3 deletions
diff --git a/setup.cfg b/setup.cfg
index e41b58f..054c9fc 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,3 +1,66 @@
+[metadata]
+
+name = alembic
+
+# version comes from setup.py; setuptools
+# can't read the "attr:" here without importing
+# until version 47.0.0 which is too recent
+
+
+description = A database migration tool for SQLAlchemy.
+long_description = file: README.rst
+long_description_content_type = text/x-rst
+url=https://alembic.sqlalchemy.org
+author = Mike Bayer
+author_email = mike_mp@zzzcomputing.com
+license = MIT
+license_file = LICENSE
+
+
+classifiers =
+ Development Status :: 5 - Production/Stable
+ Intended Audience :: Developers
+ Environment :: Console
+ License :: OSI Approved :: MIT License
+ Operating System :: OS Independent
+ Programming Language :: Python
+ Programming Language :: Python :: 2
+ Programming Language :: Python :: 2.7
+ Programming Language :: Python :: 3
+ Programming Language :: Python :: 3.6
+ Programming Language :: Python :: 3.7
+ Programming Language :: Python :: 3.8
+ Programming Language :: Python :: 3.9
+ Programming Language :: Python :: Implementation :: CPython
+ Programming Language :: Python :: Implementation :: PyPy
+ Topic :: Database :: Front-Ends
+
+[options]
+packages = find:
+include_package_data = true
+zip_safe = false
+python_requires = >=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*, !=3.5.*
+package_dir =
+ =.
+
+install_requires =
+ SQLAlchemy>=1.3.0
+ Mako
+ python-editor>=0.3
+ python-dateutil
+
+[options.packages.find]
+exclude =
+ test*
+ examples*
+
+[options.exclude_package_data]
+'' = test*
+
+[options.entry_points]
+console_scripts =
+ alembic = alembic.config:main
+
[egg_info]
tag_build=dev
@@ -40,8 +103,9 @@ default=sqlite:///:memory:
sqlite=sqlite:///:memory:
sqlite_file=sqlite:///querytest.db
postgresql=postgresql://scott:tiger@127.0.0.1:5432/test
-mysql=mysql://scott:tiger@127.0.0.1:3306/test?charset=utf8
-mssql=mssql+pyodbc://scott:tiger@ms_2008
+mysql=mysql://scott:tiger@127.0.0.1:3306/test?charset=utf8mb4
+mariadb = mariadb://scott:tiger@127.0.0.1:3306/test?charset=utf8mb4
+mssql = mssql+pyodbc://scott:tiger^5HHH@mssql2017:1433/test?driver=ODBC+Driver+13+for+SQL+Server
oracle=oracle://scott:tiger@127.0.0.1:1521
oracle8=oracle://scott:tiger@127.0.0.1:1521/?use_ansi=0
@@ -49,7 +113,7 @@ oracle8=oracle://scott:tiger@127.0.0.1:1521/?use_ansi=0
[tool:pytest]
-addopts= --tb native -v -r fxX -p no:warnings -p no:logging --maxfail=25
+addopts= --tb native -v -r sfxX -p no:warnings -p no:logging --maxfail=25
python_files=tests/test_*.py