summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2011-11-14 23:34:17 -0500
committerMike Bayer <mike_mp@zzzcomputing.com>2011-11-14 23:34:17 -0500
commitdfba9c719f2328e8e0cd6277c362c4d780e14ef3 (patch)
tree310faa3b5d967a2286247cc3c92c7e9846d81024 /setup.py
parent1ceac5c457a6d6599e7c0ced35e998903fd362ab (diff)
downloadalembic-dfba9c719f2328e8e0cd6277c362c4d780e14ef3.tar.gz
- add argparse to install requires
- more docs - get env.py to work in --sql mode even without the DBAPI installed, using just the URL - add get_section_option()
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index cdc6483..e6e2beb 100644
--- a/setup.py
+++ b/setup.py
@@ -41,7 +41,11 @@ setup(name='alembic',
zip_safe=False,
install_requires=[
'SQLAlchemy>=0.6.0',
- 'Mako'
+ 'Mako',
+ # TODO: should this not be here if the env. is
+ # Python 2.7/3.2 ? not sure how this is supposed
+ # to be handled
+ 'argparse'
],
entry_points="""
""",