summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2019-08-26 18:46:29 -0400
committerMike Bayer <mike_mp@zzzcomputing.com>2019-08-26 18:47:48 -0400
commit230404f5fe4327c06f57cf8e5b520ca8365f822a (patch)
tree8ecccdea8a0a4f988903bec8661d5a7b77ad0aba /tox.ini
parentcf751243372044e33aa2a5450a9996d64232aa37 (diff)
downloadalembic-230404f5fe4327c06f57cf8e5b520ca8365f822a.tar.gz
remove python setup.py test
Removed the "python setup.py test" feature in favor of a straight run of "tox". Per Pypa / pytest developers, "setup.py" commands are in general headed towards deprecation in favor of tox. The tox.ini script has been updated such that running "tox" with no arguments will perform a single run of the test suite against the default installed Python interpreter. .. seealso:: https://github.com/pypa/setuptools/issues/1684 https://github.com/pytest-dev/pytest/issues/5534 Change-Id: Ib92ef8d20ad0e6f1e1b9d25051b788788cc69b02 Fixes: #592
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini5
1 files changed, 2 insertions, 3 deletions
diff --git a/tox.ini b/tox.ini
index bb19bb1..98b0514 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
-envlist = py{27,34,35,36,37}-sqla{11,12,13,master}
+envlist = py
SQLA_REPO = {env:SQLA_REPO:git+https://github.com/sqlalchemy/sqlalchemy.git}
@@ -51,9 +51,8 @@ commands=
{oracle,mssql}: python reap_dbs.py db_idents.txt
-# thanks to https://julien.danjou.info/the-best-flake8-extensions/
[testenv:pep8]
-basepython = python3.7
+basepython = python3
deps=
flake8
flake8-import-order