summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2019-01-06 12:37:53 -0500
committerMike Bayer <mike_mp@zzzcomputing.com>2019-01-06 13:22:59 -0500
commitb6e3fae3f51e46028fa33e0bbc62fb2bce08b963 (patch)
tree8f41e9a70317c2181c57c0ef2bbb4680f14b9978 /tox.ini
parent16c905b5f2a24ee7bdb766f9b60ce68e44b7dab0 (diff)
downloadalembic-b6e3fae3f51e46028fa33e0bbc62fb2bce08b963.tar.gz
pure black run + flake8
run black -l 79 against source code, set up for full flake8 testing. Change-Id: I4108e1274d49894b9898ec5bd3a1147933a473d7
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini22
1 files changed, 10 insertions, 12 deletions
diff --git a/tox.ini b/tox.ini
index 8f3640d..660761a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -55,16 +55,14 @@ commands=
{oracle}: python reap_oracle_dbs.py oracle_idents.txt
+# thanks to https://julien.danjou.info/the-best-flake8-extensions/
[testenv:pep8]
-deps=flake8
-commands = python -m flake8 {posargs}
-
-
-[flake8]
-
-show-source = True
-ignore = E711,E712,E721,D,N
-# F841,F811,F401
-exclude=.venv,.git,.tox,dist,doc,*egg,build
-
-
+deps=
+ flake8
+ flake8-import-order
+ flake8-builtins
+ flake8-docstrings
+ flake8-rst-docstrings
+ # used by flake8-rst-docstrings
+ pygments
+commands = flake8 ./alembic/ ./tests/ setup.py