summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--.pre-commit-config.yaml3
-rw-r--r--pyproject.toml2
-rw-r--r--tests/test_mysql.py4
-rw-r--r--tox.ini5
5 files changed, 11 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
index 47a52f7..4f13bf5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -15,3 +15,5 @@ coverage.xml
/scratch_test_*
/test_schema.db
.idea/
+.vscode/
+.pytest_cache/ \ No newline at end of file
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 863920f..de29c68 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -2,10 +2,9 @@
# See https://pre-commit.com/hooks.html for more hooks
repos:
- repo: https://github.com/python/black
- rev: 19.3b0
+ rev: 19.10b0
hooks:
- id: black
- args: [-l 79]
- repo: https://github.com/sqlalchemyorg/zimports
rev: master
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..a8f43fe
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,2 @@
+[tool.black]
+line-length = 79
diff --git a/tests/test_mysql.py b/tests/test_mysql.py
index 46d771b..4294a31 100644
--- a/tests/test_mysql.py
+++ b/tests/test_mysql.py
@@ -470,7 +470,7 @@ class MySQLBackendOpTest(AlterColRoundTripFixture, TestBase):
)
def test_add_timestamp_server_default_current_timestamp_bundle_onupdate(
- self
+ self,
):
# note SQLAlchemy reflection bundles the ON UPDATE part into the
# server default reflection see
@@ -485,7 +485,7 @@ class MySQLBackendOpTest(AlterColRoundTripFixture, TestBase):
)
def test_add_datetime_server_default_current_timestamp_bundle_onupdate(
- self
+ self,
):
# note SQLAlchemy reflection bundles the ON UPDATE part into the
# server default reflection see
diff --git a/tox.ini b/tox.ini
index 98b0514..e872e6e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -62,4 +62,7 @@ deps=
pydocstyle<4.0.0
# used by flake8-rst-docstrings
pygments
-commands = flake8 ./alembic/ ./tests/ setup.py docs/build/conf.py
+ black==19.10b0
+commands =
+ flake8 ./alembic/ ./tests/ setup.py docs/build/conf.py
+ black --check .