summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitreview2
-rw-r--r--CHANGES2
-rw-r--r--README.rst2
-rw-r--r--alembic/util/sqla_compat.py3
-rw-r--r--docs/build/changelog.rst31
-rw-r--r--docs/build/conf.py9
-rw-r--r--docs/build/cookbook.rst2
-rw-r--r--docs/build/front.rst18
-rw-r--r--docs/build/index.rst4
-rw-r--r--docs/build/requirements.txt2
-rw-r--r--docs/build/tutorial.rst4
-rw-r--r--docs/build/unreleased/github.rst7
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
14 files changed, 32 insertions, 58 deletions
diff --git a/.gitreview b/.gitreview
index 03a234e..e297a0a 100644
--- a/.gitreview
+++ b/.gitreview
@@ -1,6 +1,6 @@
[gerrit]
host=gerrit.sqlalchemy.org
-project=zzzeek/alembic
+project=sqlalchemy/alembic
defaultbranch=master
port=29418
diff --git a/CHANGES b/CHANGES
index ca31b2d..d4fd8d2 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,6 @@ Please see:
or
- http://alembic.zzzcomputing.com/en/latest/changelog.html
+ http://alembic.sqlalchemy.org/en/latest/changelog.html
for the current CHANGES.
diff --git a/README.rst b/README.rst
index b9a8604..41ff16a 100644
--- a/README.rst
+++ b/README.rst
@@ -74,5 +74,5 @@ The goals of Alembic are:
other databases, if you want to recreate a table in the background
on a busy system.
-Documentation and status of Alembic is at http://alembic.zzzcomputing.com/
+Documentation and status of Alembic is at https://alembic.sqlalchemy.org/
diff --git a/alembic/util/sqla_compat.py b/alembic/util/sqla_compat.py
index b55cc3f..0556124 100644
--- a/alembic/util/sqla_compat.py
+++ b/alembic/util/sqla_compat.py
@@ -140,8 +140,7 @@ class _textual_index_element(sql.ColumnElement):
is the same length as the .expressions collection. Ultimately
SQLAlchemy should support text() expressions in indexes.
- See https://bitbucket.org/zzzeek/sqlalchemy/issue/3174/\
- support-text-sent-to-indexes
+ See SQLAlchemy issue 3174.
"""
__visit_name__ = '_textual_idx_element'
diff --git a/docs/build/changelog.rst b/docs/build/changelog.rst
index 049c52d..b84d824 100644
--- a/docs/build/changelog.rst
+++ b/docs/build/changelog.rst
@@ -295,7 +295,6 @@ Changelog
.. change::
:tags: bug, autogenerate
- :pullreq: bitbucket:70
Fixed bug where comparison of ``Numeric`` types would produce
a difference if the Python-side ``Numeric`` inadvertently specified
@@ -803,7 +802,6 @@ Changelog
.. change::
:tags: bug, batch
:tickets: 361
- :pullreq: bitbucket:55
Fixed bug introduced by the fix for :ticket:`338` in version 0.8.4
where a server default could no longer be dropped in batch mode.
@@ -811,7 +809,6 @@ Changelog
.. change::
:tags: bug, batch, mssql
- :pullreq: bitbucket:53
Fixed bug where SQL Server arguments for drop_column() would not
be propagated when running under a batch block. Pull request
@@ -824,7 +821,6 @@ Changelog
.. change::
:tags: bug, autogenerate
:tickets: 335
- :pullreq: bitbucket:49
Fixed bug where the columns rendered in a ``PrimaryKeyConstraint``
in autogenerate would inappropriately render the "key" of the
@@ -857,7 +853,6 @@ Changelog
.. change::
:tags: feature, versioning
- :pullreq: bitbucket:51
A major improvement to the hash id generation function, which for some
reason used an awkward arithmetic formula against uuid4() that produced
@@ -867,7 +862,6 @@ Changelog
.. change::
:tags: feature, autogenerate
- :pullreq: github:20
Added an autogenerate renderer for the :class:`.ExecuteSQLOp` operation
object; only renders if given a plain SQL string, otherwise raises
@@ -944,7 +938,6 @@ Changelog
.. change::
:tags: bug, tests
- :pullreq: bitbucket:47
Added "pytest-xdist" as a tox dependency, so that the -n flag
in the test command works if this is not already installed.
@@ -1053,7 +1046,6 @@ Changelog
.. change::
:tags: feature, commands
- :pullreq: bitbucket:46
Added new command ``alembic edit``. This command takes the same
arguments as ``alembic show``, however runs the target script
@@ -1302,7 +1294,6 @@ Changelog
.. change::
:tags: bug, autogenerate
:tickets: 266
- :pullreq: bitbucket:39
The ``--autogenerate`` option is not valid when used in conjunction
with "offline" mode, e.g. ``--sql``. This now raises a ``CommandError``,
@@ -1394,7 +1385,6 @@ Changelog
.. change::
:tags: bug, autogenerate, postgresql
:tickets: 241
- :pullreq: bitbucket:37
Repaired issue where a server default specified without ``text()``
that represented a numeric or floating point (e.g. with decimal places)
@@ -1431,7 +1421,6 @@ Changelog
.. change::
:tags: bug, autogenerate
:tickets: 261
- :pullreq: github:17
Fixed issue in autogenerate type rendering where types that belong
to modules that have the name "sqlalchemy" in them would be mistaken
@@ -1473,7 +1462,6 @@ Changelog
.. change::
:tags: bug, mysql
:tickets: 251
- :pullreq: bitbucket:35
Fixed an issue where the MySQL routine to skip foreign-key-implicit
indexes would also catch unnamed unique indexes, as they would be
@@ -1502,7 +1490,6 @@ Changelog
.. change::
:tags: feature, autogenerate
:tickets: 178
- :pullreq: bitbucket:32
Support for autogenerate of FOREIGN KEY constraints has been added.
These are delivered within the autogenerate process in the same
@@ -1524,7 +1511,6 @@ Changelog
.. change::
:tags: bug, batch
- :pullreq: bitbucket:34
Fixed bug where the "source_schema" argument was not correctly passed
when calling :meth:`.BatchOperations.create_foreign_key`. Pull
@@ -1687,7 +1673,6 @@ Changelog
.. change::
:tags: feature, config
- :pullreq: bitbucket:33
Added new argument :paramref:`.Config.config_args`, allows a dictionary
of replacement variables to be passed which will serve as substitution
@@ -1717,7 +1702,6 @@ Changelog
.. change::
:tags: bug, operations
:tickets: 174
- :pullreq: bitbucket:29
The :meth:`.Operations.add_column` directive will now additionally emit
the appropriate ``CREATE INDEX`` statement if the
@@ -1886,7 +1870,6 @@ Changelog
.. change::
:tags: bug, mssql
- :pullreq: bitbucket:26
Fixed bug in MSSQL dialect where "rename table" wasn't using
``sp_rename()`` as is required on SQL Server. Pull request courtesy
@@ -1911,7 +1894,6 @@ Changelog
.. change::
:tags: bug
:tickets: 95
- :pullreq: bitbucket:24
A file named ``__init__.py`` in the ``versions/`` directory is now
ignored by Alembic when the collection of version files is retrieved.
@@ -1919,7 +1901,6 @@ Changelog
.. change::
:tags: bug
- :pullreq: bitbucket:23
Fixed Py3K bug where an attempt would be made to sort None against
string values when autogenerate would detect tables across multiple
@@ -1928,7 +1909,6 @@ Changelog
.. change::
:tags: bug
- :pullreq: github:15
Autogenerate render will render the arguments within a Table construct
using ``*[...]`` when the number of columns/elements is greater than
@@ -1936,7 +1916,6 @@ Changelog
.. change::
:tags: bug
- :pullreq: github:14
Fixed bug where foreign key constraints would fail to render in
autogenerate when a schema name was present. Pull request courtesy
@@ -1973,7 +1952,6 @@ Changelog
.. change::
:tags: feature
- :pullreq: github:10
Added a new accessor :attr:`.MigrationContext.config`, when used
in conjunction with a :class:`.EnvironmentContext` and
@@ -2165,7 +2143,6 @@ Changelog
.. change::
:tags: feature
- :pullreq: bitbucket:20
The :func:`.command.revision` command now returns the :class:`.Script`
object corresponding to the newly generated revision. From this
@@ -2211,7 +2188,6 @@ Changelog
.. change::
:tags: bug
- :pullreq: github:9
The :func:`.compare_metadata` public API function now takes into
account the settings for
@@ -2231,7 +2207,6 @@ Changelog
.. change::
:tags: bug
- :pullreq: bitbucket:17
Enabled schema support for index and unique constraint autodetection;
previously these were non-functional and could in some cases lead to
@@ -2337,7 +2312,6 @@ Changelog
.. change::
:tags: bug, mssql
- :pullreq: bitbucket:13
The MSSQL backend will add the batch separator (e.g. ``"GO"``)
in ``--sql`` mode after the final ``COMMIT`` statement, to ensure
@@ -2358,7 +2332,6 @@ Changelog
.. change::
:tags: feature
- :pullreq: bitbucket:12
Expanded the size of the "slug" generated by "revision" to 40
characters, which is also configurable by new field
@@ -2376,7 +2349,6 @@ Changelog
.. change::
:tags: bug
- :pullreq: bitbucket:9
Fixes to Py3k in-place compatibity regarding output encoding and related;
the use of the new io.* package introduced some incompatibilities on Py2k.
@@ -3370,8 +3342,7 @@ Changelog
The author asks that you *please* report all
issues, missing features, workarounds etc.
- to the bugtracker, at
- https://bitbucket.org/zzzeek/alembic/issues/new .
+ to the bugtracker.
.. change::
:tags:
diff --git a/docs/build/conf.py b/docs/build/conf.py
index f72d252..cbc3189 100644
--- a/docs/build/conf.py
+++ b/docs/build/conf.py
@@ -36,13 +36,12 @@ extensions = ['sphinx.ext.autodoc', 'sphinx.ext.intersphinx',
# tags to sort on inside of sections
changelog_sections = ["changed", "feature", "bug", "moved", "removed"]
-changelog_render_ticket = "https://bitbucket.org/zzzeek/alembic/issue/%s/"
-changelog_render_pullreq = "https://bitbucket.org/zzzeek/alembic/pull-request/%s"
+changelog_render_ticket = "https://github.com/sqlalchemy/alembic/issues/%s"
+changelog_render_pullreq = "https://github.com/sqlalchemy/alembic/pull/%s"
changelog_render_pullreq = {
- "bitbucket": "https://bitbucket.org/zzzeek/alembic/pull-request/%s",
- "default": "https://bitbucket.org/zzzeek/alembic/pull-request/%s",
- "github": "https://github.com/zzzeek/alembic/pull/%s",
+ "default": "https://github.com/sqlalchemy/alembic/pull/%s",
+ "github": "https://github.com/sqlalchemy/alembic/pull/%s",
}
autodoc_default_flags = ["members"]
diff --git a/docs/build/cookbook.rst b/docs/build/cookbook.rst
index ffa05a3..4ace79e 100644
--- a/docs/build/cookbook.rst
+++ b/docs/build/cookbook.rst
@@ -294,7 +294,7 @@ The Replaceable Object Structure
We first need to devise a simple format that represents the "CREATE XYZ" /
"DROP XYZ" aspect of what it is we're building. We will work with an object
that represents a textual definition; while a SQL view is an object that we can define
-using a `table-metadata-like system <https://bitbucket.org/zzzeek/sqlalchemy/wiki/UsageRecipes/Views>`_,
+using a `table-metadata-like system <https://github.com/sqlalchemy/sqlalchemy/wiki/UsageRecipes/Views>`_,
this is not so much the case for things like stored procedures, where
we pretty much need to have a full string definition written down somewhere.
We'll use a simple value object called ``ReplaceableObject`` that can
diff --git a/docs/build/front.rst b/docs/build/front.rst
index 0942207..c54ab14 100644
--- a/docs/build/front.rst
+++ b/docs/build/front.rst
@@ -7,15 +7,12 @@ Information about the Alembic project.
Project Homepage
================
-Alembic is hosted on `Bitbucket <http://bitbucket.org>`_ - the lead project
-page is at https://bitbucket.org/zzzeek/alembic. Source code is tracked here
-using `Git <http://git-scm.com/>`_.
+Alembic is hosted on GitHub at https://github.com/sqlalchemy/alembic under the SQLAlchemy organization.
-Releases and project status are available on Pypi at
-http://pypi.python.org/pypi/alembic.
+Releases and project status are available on Pypi at https://pypi.python.org/pypi/alembic.
+
+The most recent published version of this documentation should be at https://alembic.sqlalchemy.org.
-The most recent published version of this documentation should be at
-http://alembic.sqlalchemy.org/.
.. _installation:
@@ -61,8 +58,9 @@ to the Alembic Google Group at `sqlalchemy-alembic <https://groups.google.com/gr
Bugs
====
-Bugs and feature enhancements to Alembic should be reported on the `Bitbucket
-issue tracker <https://bitbucket.org/zzzeek/alembic/issues?status=new&status=open>`_.
+Bugs and feature enhancements to dogpile.cache should be reported on the `GitHub
+issue tracker
+<https://github.com/sqlalchemy/alembic/issues/>`_.
-.. _SQLAlchemy: http://www.sqlalchemy.org
+.. _SQLAlchemy: https://www.sqlalchemy.org
diff --git a/docs/build/index.rst b/docs/build/index.rst
index 17ffc06..e587cfb 100644
--- a/docs/build/index.rst
+++ b/docs/build/index.rst
@@ -2,8 +2,8 @@
Welcome to Alembic's documentation!
===================================
-`Alembic <http://bitbucket.org/zzzeek/alembic>`_ is a lightweight database migration tool for usage
-with the `SQLAlchemy <http://www.sqlalchemy.org>`_ Database Toolkit for Python.
+`Alembic <https://alembic.sqlalchemy.org>`_ is a lightweight database migration tool for usage
+with the `SQLAlchemy <https://www.sqlalchemy.org>`_ Database Toolkit for Python.
.. toctree::
:maxdepth: 3
diff --git a/docs/build/requirements.txt b/docs/build/requirements.txt
index 88f8416..6a15e33 100644
--- a/docs/build/requirements.txt
+++ b/docs/build/requirements.txt
@@ -1,4 +1,4 @@
git+https://bitbucket.org/zzzeek/changelog.git#egg=changelog
git+https://bitbucket.org/zzzeek/sphinx-paramlinks.git#egg=sphinx-paramlinks
-git+https://bitbucket.org/zzzeek/sqlalchemy.git
+git+https://github.com/sqlalchemy/sqlalchemy.git
python-dateutil
diff --git a/docs/build/tutorial.rst b/docs/build/tutorial.rst
index d6ccc90..d3ed8c6 100644
--- a/docs/build/tutorial.rst
+++ b/docs/build/tutorial.rst
@@ -2,8 +2,8 @@
Tutorial
========
-`Alembic <http://bitbucket.org/zzzeek/alembic>`_ provides for the creation, management, and invocation of *change management*
-scripts for a relational database, using `SQLAlchemy <http://www.sqlalchemy.org>`_ as the underlying engine.
+Alembic provides for the creation, management, and invocation of *change management*
+scripts for a relational database, using SQLAlchemy as the underlying engine.
This tutorial will provide a full introduction to the theory and usage of this tool.
To begin, make sure Alembic is installed as described at :ref:`installation`.
diff --git a/docs/build/unreleased/github.rst b/docs/build/unreleased/github.rst
new file mode 100644
index 0000000..9b79d81
--- /dev/null
+++ b/docs/build/unreleased/github.rst
@@ -0,0 +1,7 @@
+.. change::
+ :tags: change
+
+ Code hosting has been moved to GitHub, at
+ https://github.com/sqlalchemy/alembic. Additionally, the
+ main Alembic website documentation URL is now
+ https://alembic.sqlalchemy.org.
diff --git a/setup.py b/setup.py
index 57c95f5..e962f89 100644
--- a/setup.py
+++ b/setup.py
@@ -62,7 +62,7 @@ setup(name='alembic',
keywords='SQLAlchemy migrations',
author='Mike Bayer',
author_email='mike@zzzcomputing.com',
- url='http://bitbucket.org/zzzeek/alembic',
+ url='https://alembic.sqlalchemy.org',
license='MIT',
packages=find_packages('.', exclude=['examples*', 'test*']),
include_package_data=True,
diff --git a/tox.ini b/tox.ini
index adfbfec..8f3640d 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,7 @@
# old unicode statements flag
envlist = py{27,34,35,36,37}-sqla{10,11,12,master}, py{27}-sqla{079,084,09}
-SQLA_REPO = {env:SQLA_REPO:git+https://zzzeek@bitbucket.org/zzzeek/sqlalchemy.git}
+SQLA_REPO = {env:SQLA_REPO:git+https://github.com/sqlalchemy/sqlalchemy.git}
[testenv]
cov_args=--cov=alembic --cov-report term --cov-report xml