summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 2a8de06..f66269a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -17,6 +17,17 @@ show_error_codes = true
[[tool.mypy.overrides]]
module = [
+ 'alembic.operations.ops',
+ 'alembic.op',
+ 'alembic.context',
+ 'alembic.autogenerate.api',
+ 'alembic.runtime.*',
+]
+
+disallow_incomplete_defs = true
+
+[[tool.mypy.overrides]]
+module = [
'mako.*',
'sqlalchemy.testing.*'
]