summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRune Halvorsen <runefh@gmail.com>2009-09-26 00:30:43 +0200
committerRune Halvorsen <runefh@gmail.com>2009-09-26 00:30:43 +0200
commit4c202eb1080976b80a3d530f8022361807f35aea (patch)
tree3030f748d647eca70961f176e693fbc12af1e78d
parent8dad30612d019f2d1f35ff8b26c7039b51ee9f90 (diff)
downloadanyjson-4c202eb1080976b80a3d530f8022361807f35aea.tar.gz
Moved metadata out of meta module as it wasn't working like it0.2.2
should. Fixes #2
-rw-r--r--CHANGELOG6
-rw-r--r--anyjson/__init__.py11
-rw-r--r--anyjson/metadata.py11
-rw-r--r--setup.py11
4 files changed, 21 insertions, 18 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 5c5b091..b686f17 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -22,3 +22,9 @@
* Fixed bug that rendered the lib uninstalleable with easy_install if there
was no supported json module allready installed
+
+0.2.2
+
+ * Fixed bug #2. Installation failed if there were noe compatible json
+ implementations installed, because the module was loaeded, and threw import
+ exception during the install process. \ No newline at end of file
diff --git a/anyjson/__init__.py b/anyjson/__init__.py
index d8b69c8..fdfeece 100644
--- a/anyjson/__init__.py
+++ b/anyjson/__init__.py
@@ -1,8 +1,13 @@
-from metadata import *
+"""Wraps the best available JSON implementation available in a common
+interface"""
+
import sys
-# explicitly pull in docstring from metadata. see comments there for why.
-__doc__ = metadata.__doc__
+__version__ = "0.2.2"
+__author__ = "Rune Halvorsen <runefh@gmail.com>"
+__homepage__ = "http://bitbucket.org/runeh/anyjson/"
+__docformat__ = "restructuredtext"
+
implementation = None
"""
diff --git a/anyjson/metadata.py b/anyjson/metadata.py
deleted file mode 100644
index f44766b..0000000
--- a/anyjson/metadata.py
+++ /dev/null
@@ -1,11 +0,0 @@
-"""Wraps the best available JSON implementation available in a common
-interface"""
-
-# Note: This module is neccessary so we can load the metadata in setup.py
-# without risking that the module loading fails. It will fail if the user
-# has no json module installed, causing ImportError when importing anyjson
-
-__version__ = "0.2.1"
-__author__ = "Rune Halvorsen <runefh@gmail.com>"
-__homepage__ = "http://bitbucket.org/runeh/anyjson/"
-__docformat__ = "restructuredtext"
diff --git a/setup.py b/setup.py
index f1e6a62..cb3a264 100644
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,14 @@
from setuptools import setup, find_packages
-import anyjson.metadata as meta
-author, email = meta.__author__[:-1].split(' <')
+author = "Rune Halvorsen"
+email = "runefh@gmail.com"
+version = "0.2.2"
+desc = """Wraps the best available JSON implementation available in a common
+interface"""
setup(name='anyjson',
- version=meta.__version__,
- description=meta.__doc__,
+ version=version,
+ description=desc,
long_description=open("README").read(),
classifiers=[
'License :: OSI Approved :: BSD License',