summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRune Halvorsen <runeh@opera.com>2010-12-03 14:42:23 +0100
committerRune Halvorsen <runeh@opera.com>2010-12-03 14:42:23 +0100
commit81af6bbf1d032ccdbdcd66b29f6af7aeaaa4d8f5 (patch)
tree106258653823966b55d956358889781d9f9651fe
parent67482f39cc10ae16b8fb5e15f1d253bb38d82b4d (diff)
downloadanyjson-81af6bbf1d032ccdbdcd66b29f6af7aeaaa4d8f5.tar.gz
Added python3 support (Thanks asksol)
-rw-r--r--setup.py23
1 files changed, 20 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 036d24f..ef2372a 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,13 @@
-from setuptools import setup, find_packages
+import sys
+
+extra = {}
+if sys.version_info >= (3, 0):
+ extra.update(use_2to3=True)
+
+try:
+ from setuptools import setup, find_packages
+except ImportError:
+ from distutils.core import setup, find_packages
author = "Rune Halvorsen"
email = "runefh@gmail.com"
@@ -12,8 +21,15 @@ setup(name='anyjson',
classifiers=[
'License :: OSI Approved :: BSD License',
'Intended Audience :: Developers',
- 'Programming Language :: Python'
- ],
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.4',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.1',
+ ],
keywords='json',
author=author,
author_email=email,
@@ -23,4 +39,5 @@ setup(name='anyjson',
zip_safe=False,
platforms=["any"],
test_suite = 'nose.collector',
+ **extra
)