summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 3b4ee00..9fe4902 100644
--- a/setup.py
+++ b/setup.py
@@ -52,6 +52,19 @@ finally:
meta_fh.close()
+supported = ["yajl", "jsonlib2", "jsonlib", "simplejson",
+ "json", "django.utils.simplejson", "cjson"]
+install_requires = []
+for module in supported:
+ try:
+ __import__(module)
+ break
+ except ImportError:
+ pass
+else:
+ install_requires.append("simplejson")
+
+
setup(name='anyjson',
version=meta["VERSION"],
description=meta["doc"],
@@ -60,6 +73,7 @@ setup(name='anyjson',
url=meta["homepage"],
license='BSD',
long_description=open("README").read(),
+ install_requires=install_requires,
classifiers=[
'Development Status :: 5 - Production/Stable',
'License :: OSI Approved :: BSD License',