summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Rouse <jr@its.to>2020-07-06 22:45:58 -0700
committerGitHub <noreply@github.com>2020-07-06 22:45:58 -0700
commit699bc891844233847ca6c9cac7c8f8eede2a0eae (patch)
treed7677a11ce7d62ffa8114173e8e145bc15d72ebd
parent23aecfc5a2de4475146318e7608330fff42ef2a5 (diff)
parent4463d5f7cef8dbe8a3455603a438f0f20028f428 (diff)
downloadappdirs-699bc891844233847ca6c9cac7c8f8eede2a0eae.tar.gz
Merge pull request #134 from jdufresne/setup-py-test
Replace use of deprecated 'setup.py test'
-rw-r--r--.travis.yml2
-rw-r--r--Dockerfile4
-rw-r--r--tox.ini2
3 files changed, 4 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 7ca3c98..6becca7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,4 +9,4 @@ python:
- "3.8"
- "pypy3"
-script: python setup.py test
+script: python -m unittest discover
diff --git a/Dockerfile b/Dockerfile
index 93dd737..e4d3ae0 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -6,8 +6,8 @@ RUN apt-get -y update && apt-get -y install python3-setuptools && \
WORKDIR /app
ADD . /app
-RUN python setup.py install && python setup.py test
-RUN python3 setup.py install && python3 setup.py test
+RUN python setup.py install && python -m unittest discover
+RUN python3 setup.py install && python3 -m unittest
RUN python -m appdirs
RUN python3 -m appdirs
diff --git a/tox.ini b/tox.ini
index 736e201..52e59c0 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,4 +2,4 @@
envlist = py{27,py,35,36,37,38,py3}
[testenv]
-commands = python setup.py test
+commands = {envpython} -m unittest discover