summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Rouse <jr@its.to>2018-09-17 10:05:02 -0700
committerGitHub <noreply@github.com>2018-09-17 10:05:02 -0700
commitf169ba2b0ab9458eee6d6ce389839baf78f8c477 (patch)
tree21cb175562e9f0c39913948455896e8fbe5bcb3f
parent7f4f3b626e7f2f6f2365c77a9b7f6dac72f41f12 (diff)
parentf5ef8b9e679dc5a060f88b818783c55aa04bb3ca (diff)
downloadappdirs-f169ba2b0ab9458eee6d6ce389839baf78f8c477.tar.gz
Merge pull request #114 from jdufresne/eol
Drop support for EOL Pythons
-rw-r--r--.travis.yml3
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py11
-rw-r--r--test/test_api.py6
-rw-r--r--tox.ini2
5 files changed, 3 insertions, 21 deletions
diff --git a/.travis.yml b/.travis.yml
index cd874a5..df54228 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,10 +1,7 @@
language: python
python:
- - "2.6"
- "2.7"
- "pypy"
- - "3.2"
- - "3.3"
- "3.4"
- "3.5"
- "3.6"
diff --git a/CHANGES.rst b/CHANGES.rst
index d4cabca..a9380b7 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -4,6 +4,7 @@ appdirs Changelog
UNRELEASED
----------
- Add Python 3.7 support
+- Remove support for end-of-life Pythons 2.6, 3.2, and 3.3
appdirs 1.4.4
-------------
@@ -93,4 +94,3 @@ as `applib/location.py
`PyPM <https://code.activestate.com/pypm/>`_ in `ActivePython
<https://www.activestate.com/activepython>`_). This is basically a fork of
applib.py 1.0.1 and applib/location.py 1.0.1.
-
diff --git a/setup.py b/setup.py
index dcd0ee1..3458387 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,5 @@
#!/usr/bin/env python
-import sys
import os
-import os.path
# appdirs is a dependency of setuptools, so allow installing without it.
try:
from setuptools import setup
@@ -9,10 +7,6 @@ except ImportError:
from distutils.core import setup
import ast
-tests_require = []
-if sys.version_info < (2, 7):
- tests_require.append("unittest2")
-
def read(fname):
inf = open(os.path.join(os.path.dirname(__file__), fname))
@@ -41,11 +35,8 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
@@ -54,8 +45,6 @@ setup(
'Programming Language :: Python :: Implementation :: CPython',
'Topic :: Software Development :: Libraries :: Python Modules',
],
- test_suite='test.test_api',
- tests_require=tests_require,
keywords='application directory log cache user',
author='Trent Mick',
author_email='trentm@gmail.com',
diff --git a/test/test_api.py b/test/test_api.py
index aac4540..8c89fb2 100644
--- a/test/test_api.py
+++ b/test/test_api.py
@@ -1,11 +1,7 @@
import sys
+import unittest
import appdirs
-if sys.version_info < (2, 7):
- import unittest2 as unittest
-else:
- import unittest
-
if sys.version_info[0] < 3:
STRING_TYPE = basestring
else:
diff --git a/tox.ini b/tox.ini
index 54482d7..6d63c90 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26, py27, py32, py33, py34, py35, py36, py37
+envlist = py27, pypy, py34, py35, py36, py37
[testenv]
commands = python setup.py test