summaryrefslogtreecommitdiff
path: root/Dockerfile
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2020-02-25 20:51:20 -0800
committerJon Dufresne <jon.dufresne@gmail.com>2020-02-25 20:53:29 -0800
commit4463d5f7cef8dbe8a3455603a438f0f20028f428 (patch)
tree62431bf3310e37651bbfbd31cff6338c7bc977c2 /Dockerfile
parentf8a8e9dcbdcf212f05e610957ba6ff55294049f0 (diff)
downloadappdirs-4463d5f7cef8dbe8a3455603a438f0f20028f428.tar.gz
Replace use of deprecated 'setup.py test'
Since setuptools v41.5.0 (27 Oct 2019), the 'test' command is formally deprecated and should not be used. Now use unittest as the test entry point.
Diffstat (limited to 'Dockerfile')
-rw-r--r--Dockerfile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Dockerfile b/Dockerfile
index 93dd737..e4d3ae0 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -6,8 +6,8 @@ RUN apt-get -y update && apt-get -y install python3-setuptools && \
WORKDIR /app
ADD . /app
-RUN python setup.py install && python setup.py test
-RUN python3 setup.py install && python3 setup.py test
+RUN python setup.py install && python -m unittest discover
+RUN python3 setup.py install && python3 -m unittest
RUN python -m appdirs
RUN python3 -m appdirs