summaryrefslogtreecommitdiff
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2022-01-02 15:25:38 +0200
committerAlex Grönholm <alex.gronholm@nextday.fi>2022-01-02 15:25:38 +0200
commita0e1647117225b10e3ee96f9a895ecf2fea40eaf (patch)
tree216cba565b7fb9d1e0ecc49cb3bce6c99dc73fb9 /.pre-commit-config.yaml
parentab8c32e0a925b6dff2974f32f645c839cdb000e0 (diff)
downloadapscheduler-a0e1647117225b10e3ee96f9a895ecf2fea40eaf.tar.gz
Upgraded syntax and switched linting over to pre-commit.ci
Linting checks are now run by pre-commit.ci instead of GitHub Actions.
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml49
1 files changed, 49 insertions, 0 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 0000000..c94bdd6
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,49 @@
+repos:
+- repo: https://github.com/pre-commit/pre-commit-hooks
+ rev: v4.1.0
+ hooks:
+ - id: check-added-large-files
+ - id: check-case-conflict
+ - id: check-merge-conflict
+ - id: check-symlinks
+ - id: check-toml
+ - id: check-yaml
+ - id: debug-statements
+ - id: end-of-file-fixer
+ - id: mixed-line-ending
+ args: ["--fix=lf"]
+ - id: trailing-whitespace
+
+- repo: https://github.com/pycqa/isort
+ rev: 5.10.1
+ hooks:
+ - id: isort
+ args: ["-a", "from __future__ import annotations"]
+
+- repo: https://github.com/asottile/pyupgrade
+ rev: v2.30.1
+ hooks:
+ - id: pyupgrade
+ args: ["--py37-plus"]
+
+- repo: https://github.com/csachs/pyproject-flake8
+ rev: v0.0.1a2.post1
+ hooks:
+ - id: pyproject-flake8
+ additional_dependencies: [flake8-bugbear]
+
+- repo: https://github.com/codespell-project/codespell
+ rev: v2.1.0
+ hooks:
+ - id: codespell
+
+- repo: https://github.com/pre-commit/pygrep-hooks
+ rev: v1.9.0
+ hooks:
+ - id: python-check-blanket-noqa
+ - id: python-check-blanket-type-ignore
+ - id: python-no-eval
+ - id: python-use-type-annotations
+ - id: rst-backticks
+ - id: rst-directive-colons
+ - id: rst-inline-touching-normal