summaryrefslogtreecommitdiff
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2022-04-20 01:00:57 +0300
committerAlex Grönholm <alex.gronholm@nextday.fi>2022-04-20 01:11:20 +0300
commitb20f62d929eed84ad18020bb82dd43d8cb70da4d (patch)
treec42bf1877dd54755c55c649269e1254995bdf0c9 /.pre-commit-config.yaml
parent82992cd427a9ab2351d8e0719b82d826dff5a521 (diff)
downloadapscheduler-b20f62d929eed84ad18020bb82dd43d8cb70da4d.tar.gz
Switched to Black for code formatting
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml96
1 files changed, 53 insertions, 43 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 6dc6c9f..4b438e0 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -1,49 +1,59 @@
+# This is the configuration file for pre-commit (https://pre-commit.com/).
+# To use:
+# * Install pre-commit (https://pre-commit.com/#installation)
+# * Copy this file as ".pre-commit-config.yaml"
+# * Run "pre-commit install".
repos:
-- repo: https://github.com/pre-commit/pre-commit-hooks
- rev: v4.2.0
- hooks:
- - id: check-added-large-files
- - id: check-case-conflict
- - id: check-merge-conflict
- - id: check-symlinks
- - id: check-toml
- - id: check-yaml
- - id: debug-statements
- - id: end-of-file-fixer
- - id: mixed-line-ending
- args: ["--fix=lf"]
- - id: trailing-whitespace
+ - repo: https://github.com/pre-commit/pre-commit-hooks
+ rev: v4.2.0
+ hooks:
+ - id: check-added-large-files
+ - id: check-case-conflict
+ - id: check-merge-conflict
+ - id: check-symlinks
+ - id: check-toml
+ - id: check-yaml
+ - id: debug-statements
+ - id: end-of-file-fixer
+ - id: mixed-line-ending
+ args: [ "--fix=lf" ]
+ - id: trailing-whitespace
-- repo: https://github.com/pycqa/isort
- rev: 5.10.1
- hooks:
- - id: isort
- args: ["-a", "from __future__ import annotations"]
+ - repo: https://github.com/asottile/pyupgrade
+ rev: v2.32.0
+ hooks:
+ - id: pyupgrade
+ args: [ "--py37-plus" ]
-- repo: https://github.com/asottile/pyupgrade
- rev: v2.32.0
- hooks:
- - id: pyupgrade
- args: ["--py37-plus"]
+ - repo: https://github.com/psf/black
+ rev: 22.3.0
+ hooks:
+ - id: black
-- repo: https://github.com/csachs/pyproject-flake8
- rev: v0.0.1a4
- hooks:
- - id: pyproject-flake8
- additional_dependencies: [flake8-bugbear]
+ - repo: https://github.com/pycqa/isort
+ rev: 5.10.1
+ hooks:
+ - id: isort
+ args: [ "-a", "from __future__ import annotations" ]
-- repo: https://github.com/codespell-project/codespell
- rev: v2.1.0
- hooks:
- - id: codespell
+ - repo: https://github.com/csachs/pyproject-flake8
+ rev: v0.0.1a4
+ hooks:
+ - id: pyproject-flake8
+ additional_dependencies: [ flake8-bugbear ]
-- repo: https://github.com/pre-commit/pygrep-hooks
- rev: v1.9.0
- hooks:
- - id: python-check-blanket-noqa
- - id: python-check-blanket-type-ignore
- - id: python-no-eval
- - id: python-use-type-annotations
- - id: rst-backticks
- - id: rst-directive-colons
- - id: rst-inline-touching-normal
+ - repo: https://github.com/codespell-project/codespell
+ rev: v2.1.0
+ hooks:
+ - id: codespell
+
+ - repo: https://github.com/pre-commit/pygrep-hooks
+ rev: v1.9.0
+ hooks:
+ - id: python-check-blanket-noqa
+ - id: python-check-blanket-type-ignore
+ - id: python-no-eval
+ - id: python-use-type-annotations
+ - id: rst-backticks
+ - id: rst-directive-colons
+ - id: rst-inline-touching-normal