summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2022-07-29 00:20:01 +0300
committerAlex Grönholm <alex.gronholm@nextday.fi>2022-07-29 00:20:01 +0300
commit172edec65214ff00fcfd792e86ea46e3a7e60178 (patch)
tree3c64010ba51ad371fdee6720926bd9bd3700813f
parent467b978df7c4d4da78514f1db6d78c8d48d0fa45 (diff)
downloadapscheduler-172edec65214ff00fcfd792e86ea46e3a7e60178.tar.gz
Automatically test on Python 3.11 too
-rw-r--r--.github/workflows/test.yml2
-rw-r--r--pyproject.toml2
2 files changed, 3 insertions, 1 deletions
diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
index b869cc1..94b8031 100644
--- a/.github/workflows/test.yml
+++ b/.github/workflows/test.yml
@@ -10,7 +10,7 @@ jobs:
strategy:
fail-fast: false
matrix:
- python-version: ["3.7", "3.10"]
+ python-version: ["3.7", "3.10", "3.11-dev"]
runs-on: ubuntu-latest
steps:
- uses: actions/checkout@v2
diff --git a/pyproject.toml b/pyproject.toml
index 816a9a7..be3ea9d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -20,6 +20,7 @@ classifiers = [
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
]
keywords = ["scheduling cron"]
license = {text = "MIT"}
@@ -46,6 +47,7 @@ test = [
"cbor2 >= 5.0",
"coverage",
"freezegun",
+ "greenlet >= 2.0.0a2; python_version >= '3.11'",
"paho-mqtt >= 1.5",
"psycopg2",
"pymongo >= 4",