summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2022-04-26 01:35:53 +0300
committerAlex Grönholm <alex.gronholm@nextday.fi>2022-07-19 00:48:06 +0300
commit92219f0f86366583faa709e41b4e69453dcf2390 (patch)
treed8238ac6e3584f6f819f24fb2191b43e866261ed /pyproject.toml
parentb4715e05b9c41be8684260b5bde404c6a8cfb909 (diff)
downloadapscheduler-92219f0f86366583faa709e41b4e69453dcf2390.tar.gz
Migrated project metadata from setup.cfg to pyproject.toml
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml63
1 files changed, 60 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index df9d5a7..00f51e1 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,11 +1,68 @@
[build-system]
requires = [
- "setuptools >= 42",
- "wheel >= 0.29.0",
- "setuptools_scm[toml] >= 3.4"
+ "setuptools >= 61",
+ "setuptools_scm[toml] >= 6.4"
]
build-backend = "setuptools.build_meta"
+[project]
+name = "APScheduler"
+description = "In-process task scheduler with Cron-like capabilities"
+readme = "README.rst"
+authors = [{name = "Alex Grönholm", email = "alex.gronholm@nextday.fi"}]
+classifiers = [
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3 :: Only",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+]
+keywords = ["scheduling cron"]
+license = {text = "MIT"}
+urls = {Homepage = "https://github.com/agronholm/apscheduler"}
+requires-python = ">= 3.7"
+dependencies = [
+ "anyio ~= 3.0",
+ "attrs >= 21.3",
+ "tenacity ~= 8.0",
+ "tzlocal >= 3.0",
+]
+dynamic = ["version"]
+
+[project.optional-dependencies]
+asyncpg = ["asyncpg >= 0.20"]
+cbor = ["cbor2 >= 5.0"]
+mongodb = ["pymongo >= 4"]
+mqtt = ["paho-mqtt >= 1.5"]
+redis = ["redis >= 4.0"]
+sqlalchemy = ["sqlalchemy >= 1.4.22"]
+test = [
+ "asyncpg >= 0.20",
+ "cbor2 >= 5.0",
+ "coverage",
+ "freezegun",
+ "paho-mqtt >= 1.5",
+ "psycopg2",
+ "pymongo >= 4",
+ "pymysql[rsa]",
+ "pytest >= 5.0",
+ "pytest-cov",
+ "pytest-freezegun",
+ "pytest-lazy-fixture",
+ "pytest-mock",
+ "redis[hiredis] >= 4.0",
+ "sqlalchemy >= 1.4.22",
+ "trio",
+]
+doc = [
+ "sphinx",
+ "sphinx-rtd-theme",
+]
+
[tool.setuptools_scm]
version_scheme = "post-release"
local_scheme = "dirty-tag"