summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2021-08-29 16:06:44 +0300
committerAlex Grönholm <alex.gronholm@nextday.fi>2021-08-29 16:08:49 +0300
commitaff60414a55e89140969471c4e6ee1e3ca7e535f (patch)
treed4b4d69c50c7464837b0154508f02771e14209c4 /pyproject.toml
parent7cc6c878f7c438aa8e7d9b8c636071bc028befec (diff)
downloadapscheduler-aff60414a55e89140969471c4e6ee1e3ca7e535f.tar.gz
Added mypy configuration
Using Python 3.10 syntax annotations enables us to further modernize the code base.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 75285ca..a887726 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -32,3 +32,7 @@ max_line_length = 99
[tool.flake8]
max-line-length = 99
+
+[tool.mypy]
+python_version = "3.10"
+ignore_missing_imports = true