summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2022-09-22 01:00:16 +0300
committerAlex Grönholm <alex.gronholm@nextday.fi>2022-09-22 01:00:16 +0300
commitb3c6bca584db5658dfcae8ad02ab39aa07fb9cbc (patch)
treef43422a87ed5f61e40186d3e0ec2ee188820bb56 /pyproject.toml
parent40cf1621c6574cdbff9aaffa7b6ae83e1bf349d9 (diff)
downloadapscheduler-b3c6bca584db5658dfcae8ad02ab39aa07fb9cbc.tar.gz
Fixed the test suite on PyPy
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml18
1 files changed, 12 insertions, 6 deletions
diff --git a/pyproject.toml b/pyproject.toml
index a45f573..ef794e8 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -41,16 +41,19 @@ cbor = ["cbor2 >= 5.0"]
mongodb = ["pymongo >= 4"]
mqtt = ["paho-mqtt >= 1.5"]
redis = ["redis >= 4.0"]
-sqlalchemy = ["sqlalchemy >= 1.4.22"]
+sqlalchemy = [
+ "sqlalchemy >= 1.4.22",
+ "greenlet >= 2.0.0a2; python_version >= '3.11'"
+]
test = [
- "asyncpg >= 0.20",
- "asyncmy >= 0.2.5",
- "cbor2 >= 5.0",
+ "APScheduler[cbor,mongodb,mqtt,redis,sqlalchemy]",
+ "APScheduler[asyncpg]; python_implementation == 'CPython'",
+ "asyncmy >= 0.2.5; python_implementation == 'CPython'",
"coverage",
"freezegun",
- "greenlet >= 2.0.0a2; python_version >= '3.11'",
"paho-mqtt >= 1.5",
- "psycopg2",
+ "psycopg2; python_implementation == 'CPython'",
+ "psycopg2cffi; python_implementation != 'CPython'",
"pymongo >= 4",
"pymysql[rsa]",
"pytest >= 5.0",
@@ -110,6 +113,9 @@ isolated_build = true
extras = test
commands = coverage run -m pytest {posargs}
+[testenv:pypy3]
+commands = pytest {posargs}
+
[testenv:pyright]
deps = pyright
commands = pyright --verifytypes apscheduler