summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--pyproject.toml7
-rw-r--r--tox.ini2
2 files changed, 8 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 95b48ac..8d00597 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,2 +1,7 @@
[build-system]
-requires = ["setuptools >= 36.2.7", "wheel", "setuptools_scm >= 1.7.0"]
+requires = [
+ "setuptools >= 40.0.4",
+ "setuptools_scm >= 2.0.0",
+ "wheel >= 0.29.0",
+]
+build-backend = "setuptools.build_meta"
diff --git a/tox.ini b/tox.ini
index 3eb99db..6e452ad 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,8 @@
[tox]
+minversion = 3.3.0
envlist = py35, py36, py37, py38, pypy3, flake8
skip_missing_interpreters = true
+isolated_build = true
[testenv]
commands = python -m pytest {posargs}