summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.rst20
-rw-r--r--MANIFEST.in3
-rw-r--r--apscheduler/__init__.py2
-rw-r--r--setup.cfg8
-rw-r--r--setup.py2
5 files changed, 32 insertions, 3 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index b3172a6..3135d88 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -4,6 +4,26 @@ Version history
To find out how to migrate your application from a previous version of
APScheduler, see the :doc:`migration section <migration>`.
+2.0.3
+-----
+
+* The scheduler now closes the job store that is being removed, and all job stores on shutdown() by default
+
+* Added the ``last`` expression in the day field of CronTrigger (thanks rcaselli)
+
+* Raise a TypeError when fields with invalid names are passed to CronTrigger (thanks Christy O'Reilly)
+
+* Fixed the persistent.py example by shutting down the scheduler on Ctrl+C
+
+* Added PyPy 1.8 and CPython 3.3 to the test suite
+
+* Dropped PyPy 1.4 - 1.5 and CPython 3.1 from the test suite
+
+* Updated setup.cfg for compatibility with distutils2/packaging
+
+* Examples, documentation sources and unit tests are now packaged in the source distribution
+
+
2.0.2
-----
diff --git a/MANIFEST.in b/MANIFEST.in
index 9561fb1..31b7e02 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1 +1,4 @@
include README.rst
+recursive-include tests *.py
+recursive-include examples *.py
+recursive-include docs *.rst *.py
diff --git a/apscheduler/__init__.py b/apscheduler/__init__.py
index a55959f..08d5213 100644
--- a/apscheduler/__init__.py
+++ b/apscheduler/__init__.py
@@ -1,3 +1,3 @@
-version_info = (2, 0, 2)
+version_info = (2, 0, 3)
version = '.'.join(str(n) for n in version_info[:3])
release = version + ''.join(str(n) for n in version_info[3:])
diff --git a/setup.cfg b/setup.cfg
index 033c8b1..a64bb99 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -7,7 +7,7 @@ upload-dir = docs/_build/html
[metadata]
name = APScheduler
-version = 2.0.0rc1
+version = 2.0.3
author = Alex Grönholm
author-email = apscheduler@nextday.fi
summary = In-process task scheduler with Cron-like capabilities
@@ -27,6 +27,7 @@ classifier = Development Status :: 5 - Production/Stable
Programming Language :: Python :: 3
Programming Language :: Python :: 3.1
Programming Language :: Python :: 3.2
+ Programming Language :: Python :: 3.3
[files]
packages =
@@ -37,3 +38,8 @@ packages =
extra_files =
setup.py
+ README.rst
+ recursive-include examples *.py
+ recursive-include tests *.py
+ recursive-include docs *.rst *.py
+
diff --git a/setup.py b/setup.py
index 109b8d1..2cb3411 100644
--- a/setup.py
+++ b/setup.py
@@ -32,10 +32,10 @@ setup(
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.1',
'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3'
],
keywords='scheduling cron',
license='MIT',
packages=('apscheduler', 'apscheduler.jobstores', 'apscheduler.triggers',
'apscheduler.triggers.cron'),
- **extras
)