summaryrefslogtreecommitdiff
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorpre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com>2022-08-08 20:19:40 +0200
committerGitHub <noreply@github.com>2022-08-08 20:19:40 +0200
commit09e5ce9152d979ad9b53f4f798b98d4ac186d145 (patch)
tree0cd54fa8032c92533c407b2fcb0caa2487b7fdcc /.pre-commit-config.yaml
parentb92f2ebe8d055fdb130292958f13fd401484315b (diff)
downloadastroid-git-09e5ce9152d979ad9b53f4f798b98d4ac186d145.tar.gz
[pre-commit.ci] pre-commit autoupdate (#1726)
* [pre-commit.ci] pre-commit autoupdate updates: - [github.com/asottile/pyupgrade: v2.37.2 → v2.37.3](https://github.com/asottile/pyupgrade/compare/v2.37.2...v2.37.3) - https://github.com/Pierre-Sassoulas/black-disable-checker/: v1.1.0 → v1.1.1 - [github.com/PyCQA/flake8: 4.0.1 → 5.0.3](https://github.com/PyCQA/flake8/compare/4.0.1...5.0.3) * Disable line too long and line break before binary operator As there's a lot of the format and the latter is incompatible with black. * [flake8] Deactivate the check for return and yield together It's opinionated see https://github.com/PyCQA/flake8-bugbear/issues/2 and every current warning is a false positive. * Explain falke8 disables Co-authored-by: pre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com> Co-authored-by: Pierre Sassoulas <pierre.sassoulas@gmail.com> Co-authored-by: Daniël van Noord <13665637+DanielNoord@users.noreply.github.com>
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml6
1 files changed, 3 insertions, 3 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 0d6d5fae..23ec95c7 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -28,7 +28,7 @@ repos:
exclude: tests/testdata|setup.py
types: [python]
- repo: https://github.com/asottile/pyupgrade
- rev: v2.37.2
+ rev: v2.37.3
hooks:
- id: pyupgrade
exclude: tests/testdata
@@ -39,7 +39,7 @@ repos:
- id: isort
exclude: tests/testdata
- repo: https://github.com/Pierre-Sassoulas/black-disable-checker/
- rev: v1.1.0
+ rev: v1.1.1
hooks:
- id: black-disable-checker
exclude: tests/unittest_nodes_lineno.py
@@ -50,7 +50,7 @@ repos:
args: [--safe, --quiet]
exclude: tests/testdata
- repo: https://github.com/PyCQA/flake8
- rev: 4.0.1
+ rev: 5.0.3
hooks:
- id: flake8
additional_dependencies: