summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorClaudiu Popa <pcmanticore@gmail.com>2015-12-11 00:02:57 +0200
committerClaudiu Popa <pcmanticore@gmail.com>2015-12-11 00:02:57 +0200
commit9f8aee71c9b15fa93a55a6f50cb53458bc864c8e (patch)
tree00a3aa88d129e1c3288fa88d0e008959bd899791 /README.rst
parent31fd52cee82429f55674d3232d2f5c9eb45595af (diff)
downloadastroid-git-9f8aee71c9b15fa93a55a6f50cb53458bc864c8e.tar.gz
Change the extension of the README file, so it gets rendered by github.
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst64
1 files changed, 64 insertions, 0 deletions
diff --git a/README.rst b/README.rst
new file mode 100644
index 00000000..b19aca87
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,64 @@
+.. image:: https://drone.io/bitbucket.org/logilab/astroid/status.png
+ :alt: drone.io Build Status
+ :target: https://drone.io/bitbucket.org/logilab/astroid
+
+Astroid
+=======
+
+What's this?
+------------
+
+The aim of this module is to provide a common base representation of
+python source code for projects such as pychecker, pyreverse,
+pylint... Well, actually the development of this library is essentially
+governed by pylint's needs. It used to be called logilab-astng.
+
+It provides a compatible representation which comes from the `_ast`
+module. It rebuilds the tree generated by the builtin _ast module by
+recursively walking down the AST and building an extended ast. The new
+node classes have additional methods and attributes for different
+usages. They include some support for static inference and local name
+scopes. Furthermore, astroid builds partial trees by inspecting living
+objects.
+
+Main modules are:
+
+* `bases`, `node_classses` and `scoped_nodes` contain the classes for the
+ different type of nodes of the tree.
+
+* the `manager` contains a high level object to get astroid trees from
+ source files and living objects. It maintains a cache of previously
+ constructed tree for quick access.
+
+
+Installation
+------------
+
+Extract the tarball, jump into the created directory and run::
+
+ python setup.py install
+
+For installation options, see::
+
+ python setup.py install --help
+
+
+If you have any questions, please mail the code-quality@python.org
+mailing list for support. See
+http://mail.python.org/mailman/listinfo/code-quality for subscription
+information and archives. You may find older archives at
+http://lists.logilab.org/mailman/listinfo/python-projects .
+
+Python Versions
+---------------
+
+astroid is compatible with Python 2.7 as well as 3.3 and later. astroid uses
+the same code base for both Python versions, using six.
+
+Test
+----
+
+Tests are in the 'test' subdirectory. To launch the whole tests suite
+at once, you can use unittest discover::
+
+ python -m unittest discover -p "unittest*.py"