summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2021-06-15 20:30:52 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2021-06-16 06:57:01 +0200
commit2ea343c99e09d526729d2b6ffd82ee7f7ac5ec4b (patch)
tree55ccfad615791eefcbc7a2e2aea6a59cda776619 /doc
parent67b6f3ef59effc53e6d3f4c9e0082e882fc5d5c7 (diff)
downloadastroid-git-2ea343c99e09d526729d2b6ffd82ee7f7ac5ec4b.tar.gz
Add release.yml file for automated release with Github Action
See https://github.com/cdce8p/python-typing-update/blob/f79966eb104f220fdcc78f87764eb74ab6e527c2/.github/workflows/release.yaml
Diffstat (limited to 'doc')
-rw-r--r--doc/release.md15
1 files changed, 2 insertions, 13 deletions
diff --git a/doc/release.md b/doc/release.md
index 7354b2e2..28b9c4ce 100644
--- a/doc/release.md
+++ b/doc/release.md
@@ -8,18 +8,7 @@ So, you want to release the `X.Y.Z` version of astroid ?
2. Install the release dependencies `pip3 install pre-commit tbump`
3. Bump the version and release by using `tbump X.Y.Z --no-push`.
4. Check the result.
-5. Until the release is done via GitHub actions on tag, run the following commands:
-
-```bash
-git clean -fdx && find . -name '*.pyc' -delete
-python3 -m venv venv
-source venv/bin/activate
-pip3 install twine wheel setuptools
-python setup.py sdist --formats=gztar bdist_wheel
-twine upload dist/*
-```
-
-6. Push the tag.
+5. Push the tag.
## Post release
@@ -28,7 +17,7 @@ twine upload dist/*
Move back to a dev version with `tbump`:
```bash
-tbump X.Y.Z-dev0 --no-tag --no-push
+tbump X.Y.Z-dev0 --no-tag --no-push # You can interrupt during copyrite
```
Check the result and then upgrade the master branch