summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2021-06-15 13:02:57 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2021-06-16 06:57:01 +0200
commit4190036453d0e430d84cd1f6129491a953b7d300 (patch)
tree145f0baff74f7ceef67e17c20268a75c36a351ac /doc
parentdabd881e4817fae130aa8e485ec62db27136e197 (diff)
downloadastroid-git-4190036453d0e430d84cd1f6129491a953b7d300.tar.gz
Apply pre-commit to cleanup the result of copyrite
Diffstat (limited to 'doc')
-rw-r--r--doc/release.md10
1 files changed, 5 insertions, 5 deletions
diff --git a/doc/release.md b/doc/release.md
index 04d323d7..935a6bfe 100644
--- a/doc/release.md
+++ b/doc/release.md
@@ -6,11 +6,9 @@ So, you want to release the `X.Y.Z` version of astroid ?
1. Check if the dependencies of the package are correct
2. Install the release dependencies `pip3 install pre-commit tbump`
-3. Bump the version and release by using `tbump X.Y.Z --no-push`. During the commit
- pre-commit and pyupgrade should remove the `encode utf8` automatically
-4. Check the result and then push the tag.
-
-Until the release is done via GitHub actions on tag, run the following commands:
+3. Bump the version and release by using `tbump X.Y.Z --no-push`.
+4. Check the result.
+5. Until the release is done via GitHub actions on tag, run the following commands:
```bash
git clean -fdx && find . -name '*.pyc' -delete
@@ -21,6 +19,8 @@ python setup.py sdist --formats=gztar bdist_wheel
twine upload dist/*
```
+6. Push the tag.
+
## Post release
### Back to a dev version