summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMarc Mueller <30130371+cdce8p@users.noreply.github.com>2022-06-29 09:58:46 +0200
committerGitHub <noreply@github.com>2022-06-29 09:58:46 +0200
commit1c3c18f4126a84b83941fef666ff03c0e7c6cabb (patch)
treeb3e3e72f5b68a31f8c6f35b239fc86373c20724f /pyproject.toml
parent88ccd6fd0d8111b3aacedc4a0d3466468dc0e217 (diff)
downloadastroid-git-1c3c18f4126a84b83941fef666ff03c0e7c6cabb.tar.gz
Improve packaging [PEP 517 + 621] (#1670)
* Use isolated build environments * Use new project metadata format [PEP 621] * Move remaining flake8 config to setup.cfg * Update pre-commit config
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 00000000..ae1d9744
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,55 @@
+[build-system]
+requires = ["setuptools~=62.6", "wheel~=0.37.1"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "astroid"
+license = {text = "LGPL-2.1-or-later"}
+description = "An abstract syntax tree for Python with inference support."
+readme = "README.rst"
+authors = [
+ {name = "Python Code Quality Authority", email = "code-quality@python.org"}
+]
+keywords = ["static code analysis", "python", "abstract syntax tree"]
+classifiers = [
+ "Development Status :: 6 - Mature",
+ "Environment :: Console",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: GNU Lesser General Public License v2 (LGPLv2)",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3 :: Only",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Topic :: Software Development :: Quality Assurance",
+ "Topic :: Software Development :: Testing",
+]
+requires-python = ">=3.7.2"
+dependencies = [
+ "lazy_object_proxy>=1.4.0",
+ "wrapt>=1.11,<2",
+ "typed-ast>=1.4.0,<2.0;implementation_name=='cpython' and python_version<'3.8'",
+ "typing-extensions>=3.10;python_version<'3.10'",
+]
+dynamic = ["version"]
+
+[project.urls]
+"Docs" = "https://pylint.pycqa.org/projects/astroid/en/latest/"
+"Source Code" = "https://github.com/PyCQA/astroid"
+"Bug tracker" = "https://github.com/PyCQA/astroid/issues"
+"Discord server" = "https://discord.gg/Egy6P8AMB5"
+
+[tool.setuptools]
+license-files = ["LICENSE", "CONTRIBUTORS.txt"] # Keep in sync with setup.cfg
+
+[tool.setuptools.packages.find]
+include = ["astroid*"]
+
+[tool.setuptools.dynamic]
+version = {attr = "astroid.__pkginfo__.__version__"}