summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorChristian Clauss <cclauss@me.com>2022-09-18 09:28:34 +0200
committerGitHub <noreply@github.com>2022-09-18 09:28:34 +0200
commit354e4dfbeb140d66b88edfa681df2063d6ae1a9a (patch)
treeecdf9bf94ea1d85f320d5f1c85c8835926badff0 /pyproject.toml
parentbed16016ae465cd6d19aa01ad5772e9d5045bbdc (diff)
downloadastroid-git-354e4dfbeb140d66b88edfa681df2063d6ae1a9a.tar.gz
Migrate configs for isort, mypy, and pytest into pyproject.toml (#1789)
Co-authored-by: Pierre Sassoulas <pierre.sassoulas@gmail.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index cc724ed4..66a52f5c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -54,3 +54,41 @@ include = ["astroid*"]
[tool.setuptools.dynamic]
version = {attr = "astroid.__pkginfo__.__version__"}
+
+[tool.aliases]
+test = "pytest"
+
+[tool.pytest.ini_options]
+addopts = '-m "not acceptance"'
+python_files = ["*test_*.py"]
+testpaths = ["tests"]
+
+[tool.isort]
+include_trailing_comma = true
+known_first_party = ["astroid"]
+known_third_party = ["attr", "nose", "numpy", "pytest", "six", "sphinx"]
+line_length = 88
+multi_line_output = 3
+skip_glob = ["tests/testdata"]
+
+[tool.mypy]
+enable_error_code = "ignore-without-code"
+no_implicit_optional = true
+scripts_are_modules = true
+show_error_codes = true
+warn_redundant_casts = true
+
+[[tool.mypy.overrides]]
+# Importlib typeshed stubs do not include the private functions we use
+module = [
+ "_io.*",
+ "gi.*",
+ "importlib.*",
+ "lazy_object_proxy.*",
+ "nose.*",
+ "numpy.*",
+ "pytest",
+ "setuptools",
+ "wrapt.*",
+]
+ignore_missing_imports = true