summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMarc Mueller <30130371+cdce8p@users.noreply.github.com>2023-04-23 23:53:59 +0200
committerGitHub <noreply@github.com>2023-04-23 23:53:59 +0200
commita91a8d60ccd5ca8e5f8e162d67b3b93444105235 (patch)
tree7087fd6ddbabfc81f99627f1122f8092bec977fc /pyproject.toml
parente49bfaa2229e2ce27b7a212ad3ebe378dc17f613 (diff)
downloadastroid-git-a91a8d60ccd5ca8e5f8e162d67b3b93444105235.tar.gz
Drop support for Python 3.7 (#2137)
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 1 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 991876e0..dd136823 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -17,7 +17,6 @@ classifiers = [
"Programming Language :: Python",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3 :: Only",
- "Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
@@ -28,10 +27,9 @@ classifiers = [
"Topic :: Software Development :: Quality Assurance",
"Topic :: Software Development :: Testing",
]
-requires-python = ">=3.7.2"
+requires-python = ">=3.8.0"
dependencies = [
"lazy_object_proxy>=1.4.0",
- "typed-ast>=1.4.0,<2.0;implementation_name=='cpython' and python_version<'3.8'",
"typing-extensions>=4.0.0;python_version<'3.11'",
]
dynamic = ["version"]