summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2021-04-10 16:47:18 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2021-04-24 14:33:41 +0200
commit13405cf0ecd61347011d6e7d9297b6b06ce2a571 (patch)
tree8e133efa1880773c96f7149a3a24e253dc9fb9f8 /setup.cfg
parentfcbf3c923136ef25d01ec45cd550d93f319b04db (diff)
downloadastroid-git-13405cf0ecd61347011d6e7d9297b6b06ce2a571.tar.gz
Move information to setup.py from __pgkinfo__
Move packaging information from setup.py to setup.cfg
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.cfg b/setup.cfg
index 4a709ce3..4501d9eb 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -11,6 +11,7 @@ license_files =
LICENSE
classifiers =
Development Status :: 6 - Mature
+ Environment :: Console
Intended Audience :: Developers
License :: OSI Approved :: GNU Lesser General Public License v2 (LGPLv2)
Operating System :: OS Independent
@@ -33,12 +34,17 @@ project_urls =
"Mailing list" = mailto:code-quality@python.org
[options]
+packages = find:
install_requires =
lazy_object_proxy>=1.4.0
wrapt>=1.11,<1.13
typed-ast>=1.4.0,<1.5;implementation_name=="cpython" and python_version<"3.8"
python_requires = ~=3.6
+[options.packages.find]
+include =
+ astroid*
+
[aliases]
test = pytest