summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorMarc Mueller <30130371+cdce8p@users.noreply.github.com>2022-06-29 09:58:46 +0200
committerGitHub <noreply@github.com>2022-06-29 09:58:46 +0200
commit1c3c18f4126a84b83941fef666ff03c0e7c6cabb (patch)
treeb3e3e72f5b68a31f8c6f35b239fc86373c20724f /setup.cfg
parent88ccd6fd0d8111b3aacedc4a0d3466468dc0e217 (diff)
downloadastroid-git-1c3c18f4126a84b83941fef666ff03c0e7c6cabb.tar.gz
Improve packaging [PEP 517 + 621] (#1670)
* Use isolated build environments * Use new project metadata format [PEP 621] * Move remaining flake8 config to setup.cfg * Update pre-commit config
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg57
1 files changed, 13 insertions, 44 deletions
diff --git a/setup.cfg b/setup.cfg
index b1943a12..eb7d6f38 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,51 +1,12 @@
+# Setuptools v62.6 doesn't support editable installs with just 'pyproject.toml' (PEP 660).
+# Keep this file until it does!
+
[metadata]
-name = astroid
-description = An abstract syntax tree for Python with inference support.
-version = attr: astroid.__pkginfo__.__version__
-long_description = file: README.rst
-long_description_content_type = text/x-rst
-url = https://github.com/PyCQA/astroid
-author = Python Code Quality Authority
-author_email = code-quality@python.org
-license = LGPL-2.1-or-later
+# wheel doesn't yet read license_files from pyproject.toml - tools.setuptools
+# Keep it here until it does!
license_files =
LICENSE
CONTRIBUTORS.txt
-classifiers =
- Development Status :: 6 - Mature
- Environment :: Console
- Intended Audience :: Developers
- License :: OSI Approved :: GNU Lesser General Public License v2 (LGPLv2)
- Operating System :: OS Independent
- Programming Language :: Python
- Programming Language :: Python :: 3
- Programming Language :: Python :: 3 :: Only
- Programming Language :: Python :: 3.7
- Programming Language :: Python :: 3.8
- Programming Language :: Python :: 3.9
- Programming Language :: Python :: 3.10
- Programming Language :: Python :: Implementation :: CPython
- Programming Language :: Python :: Implementation :: PyPy
- Topic :: Software Development :: Libraries :: Python Modules
- Topic :: Software Development :: Quality Assurance
- Topic :: Software Development :: Testing
-keywords = static code analysis,python,abstract syntax tree
-project_urls =
- Bug tracker = https://github.com/PyCQA/astroid/issues
- Discord server = https://discord.gg/Egy6P8AMB5
-
-[options]
-packages = find:
-install_requires =
- lazy_object_proxy>=1.4.0
- wrapt>=1.11,<2
- typed-ast>=1.4.0,<2.0;implementation_name=="cpython" and python_version<"3.8"
- typing-extensions>=3.10;python_version<"3.10"
-python_requires = >=3.7.2
-
-[options.packages.find]
-include =
- astroid*
[aliases]
test = pytest
@@ -63,6 +24,14 @@ known_first_party = astroid
include_trailing_comma = True
skip_glob = tests/testdata
+[flake8]
+extend-ignore = E203,E266,E501,C901,F401
+max-complexity = 20
+select = B,C,E,F,W,T4,B9
+# Required for flake8-typing-imports (v1.12.0)
+# The plugin doesn't yet read the value from pyproject.toml
+min_python_version = 3.7.2
+
[mypy]
scripts_are_modules = True
no_implicit_optional = True