summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog15
-rw-r--r--doc/conf.py7
-rw-r--r--pyproject.toml3
3 files changed, 18 insertions, 7 deletions
diff --git a/ChangeLog b/ChangeLog
index be5a6562..1d5bcf5e 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -61,7 +61,7 @@ Release date: TBA
Refs #1490
-What's New in astroid 2.15.3?
+What's New in astroid 2.15.4?
=============================
Release date: TBA
@@ -74,6 +74,19 @@ Release date: TBA
Closes pylint-dev/pylint#7906
+What's New in astroid 2.15.3?
+=============================
+Release date: 2023-04-16
+
+* Fix ``infer_call_result()`` crash on methods called ``with_metaclass()``.
+
+ Closes #1735
+
+* Suppress ``UserWarning`` when finding module specs.
+
+ Closes pylint-dev/pylint#7906
+
+
What's New in astroid 2.15.2?
=============================
Release date: 2023-04-03
diff --git a/doc/conf.py b/doc/conf.py
index 8523a2bd..9cdd52dd 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -55,7 +55,8 @@ master_doc = "index"
# General information about the project.
project = "Astroid"
current_year = datetime.utcnow().year
-copyright = f"2003-{current_year}, Logilab, PyCQA and contributors"
+contributors = "Logilab, and astroid contributors"
+copyright = f"2003-{current_year}, {contributors}"
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
@@ -202,7 +203,7 @@ latex_documents = [
"index",
"Astroid.tex",
"Astroid Documentation",
- "Logilab, PyCQA and contributors",
+ contributors,
"manual",
),
]
@@ -240,7 +241,7 @@ man_pages = [
"index",
"astroid",
"Astroid Documentation",
- ["Logilab, PyCQA and contributors"],
+ [contributors],
1,
)
]
diff --git a/pyproject.toml b/pyproject.toml
index 807c450c..991876e0 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -7,9 +7,6 @@ name = "astroid"
license = {text = "LGPL-2.1-or-later"}
description = "An abstract syntax tree for Python with inference support."
readme = "README.rst"
-authors = [
- {name = "Python Code Quality Authority", email = "code-quality@python.org"}
-]
keywords = ["static code analysis", "python", "abstract syntax tree"]
classifiers = [
"Development Status :: 6 - Mature",