summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Fayolle <alexandre.fayolle@logilab.fr>2006-06-14 19:32:58 +0200
committerAlexandre Fayolle <alexandre.fayolle@logilab.fr>2006-06-14 19:32:58 +0200
commitb2dffc24250fddb5b0de06495f48820488cd4ac1 (patch)
treef02d6472bb2fe7cdf031c6cb8108bedbb085a0f7
parentb265c88e0b2bfec96a5784f104da7d851cf4d576 (diff)
downloadastroid-b2dffc24250fddb5b0de06495f48820488cd4ac1.tar.gz
new python policy
-rw-r--r--debian/changelog3
-rw-r--r--debian/control21
-rw-r--r--debian/python-logilab-astng.dirs5
-rw-r--r--debian/python-logilab-astng.postinst20
-rw-r--r--debian/python-logilab-astng.prerm8
-rwxr-xr-xdebian/rules17
6 files changed, 18 insertions, 56 deletions
diff --git a/debian/changelog b/debian/changelog
index a09009d..1b805e2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,8 +3,9 @@ logilab-astng (0.16.0-2) unstable; urgency=low
* Updated standards to 3.7.2
* use debhelper 5
* fixed encoding of maintainer name in debian/control
+ * updated to new python policy (closes: #373458)
- -- Alexandre Fayolle <afayolle@debian.org> Mon, 22 May 2006 12:05:49 +0200
+ -- Alexandre Fayolle <afayolle@debian.org> Wed, 14 Jun 2006 17:59:54 +0200
logilab-astng (0.16.0-1) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 888692f..6d06e83 100644
--- a/debian/control
+++ b/debian/control
@@ -2,27 +2,24 @@ Source: logilab-astng
Section: python
Priority: optional
Maintainer: Sylvain Thénault <sylvain.thenault@logilab.fr>
-Uploader: Alexandre Fayolle <afayolle@debian.org>
-Build-Depends: debhelper (>= 5.0.0), python-dev
+Uploaders: Alexandre Fayolle <afayolle@debian.org>
+Build-Depends: debhelper (>= 5.0.37.1), python-dev (>=2.3.5-7), python (>=2.3.5-7), python-central
+XS-Python-Version: all
Standards-Version: 3.7.2
Package: python-logilab-astng
Architecture: all
-Depends: python, python-logilab-common
-Provides: python2.2-logilab-astng, python2.3-logilab-astng, python2.4-logilab-astng
-Conflicts: python2.2-logilab-astng, python2.3-logilab-astng, python2.4-logilab-astng
-Replaces: python2.2-logilab-astng, python2.3-logilab-astng, python2.4-logilab-astng
+Depends: ${python:Depends}, python-logilab-common (>= 0.16.1-2)
+XB-Python-Version: ${python:Versions}
Description: extend python's abstract syntax tree
The aim of this module is to provide a common base representation of
- python source code for projects such as pychecker, pyreverse,
- pylint... Well, actually the development of this library is essentialy
- governed by pylint's needs.
+ python source code for projects such as pyreverse or pylint.
.
- It extends class defined in the compiler.ast [1] module with some
+ It extends classes defined in the compiler.ast module with some
additional methods and attributes. Instance attributes are added by a
builder object, which can either generate extended ast (let's call
- them astng ;) by visiting an existant ast tree or by inspecting living
- object. Methods are added by monkey patching ast classes.
+ them astng ;) by visiting an existant ast tree or by inspecting
+ living object. Methods are added by monkey patching ast classes.
.
Homepage: http://www.logilab.org/projects/astng
diff --git a/debian/python-logilab-astng.dirs b/debian/python-logilab-astng.dirs
index ab6d53b..f3feac6 100644
--- a/debian/python-logilab-astng.dirs
+++ b/debian/python-logilab-astng.dirs
@@ -1,6 +1 @@
-usr/lib/site-python
-usr/lib/site-python/logilab
-usr/lib/site-python/logilab/astng
-usr/share/doc/python-logilab-astng
-usr/share/doc/python-logilab-astng
usr/share/doc/python-logilab-astng/test
diff --git a/debian/python-logilab-astng.postinst b/debian/python-logilab-astng.postinst
index 783b00e..c426afd 100644
--- a/debian/python-logilab-astng.postinst
+++ b/debian/python-logilab-astng.postinst
@@ -1,26 +1,6 @@
#! /bin/sh -e
#
-
-touch /usr/lib/site-python/logilab/__init__.py
-
-
-# precompile python files
-VERSION=2.3
-PACKAGEDIR=/usr/lib/site-python/logilab/astng
-case "$1" in
- configure|abort-upgrade|abort-remove|abort-deconfigure)
- python$VERSION -O /usr/lib/python$VERSION/compileall.py -q $PACKAGEDIR
- python$VERSION /usr/lib/python$VERSION/compileall.py -q $PACKAGEDIR
- ;;
-
- *)
- echo "postinst called with unknown argument \`$1'" >&2
- exit 1
- ;;
-esac
-
-
#DEBHELPER#
exit 0
diff --git a/debian/python-logilab-astng.prerm b/debian/python-logilab-astng.prerm
index c4cb31f..c426afd 100644
--- a/debian/python-logilab-astng.prerm
+++ b/debian/python-logilab-astng.prerm
@@ -1,14 +1,6 @@
#! /bin/sh -e
#
-# remove .pyc and .pyo files
-dpkg --listfiles python-logilab-astng |
- awk '$0~/\.py$/ {print $0"c\n" $0"o"}' |
- xargs rm -f >&2
-
-
-
-
#DEBHELPER#
exit 0
diff --git a/debian/rules b/debian/rules
index f06ae24..fb9e7a0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,10 +11,6 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-# This is the debhelper compatability version to use.
-export DH_COMPAT=5
-
-
build: build-stamp
build-stamp:
@@ -36,12 +32,11 @@ install: build
dh_testroot
dh_clean -k
dh_installdirs
- python setup.py -q install_lib --no-compile --install-dir=debian/python-logilab-astng/usr/lib/site-python
- python setup.py -q install_headers --install-dir=debian/python-logilab-astng/usr/include/
+ python setup.py -q install --no-compile --prefix=debian/python-logilab-astng/usr
# remove sub-package __init__ file (created in postinst)
- rm debian/python-logilab-astng/usr/lib/site-python/logilab/__init__.py
+ rm debian/python-logilab-astng/usr/lib/python*/site-packages/logilab/__init__.py
# remove test directory (installed in a separated package)
- rm -rf debian/python-logilab-astng/usr/lib/site-python/logilab/astng/test
+ rm -rf debian/python-logilab-astng/usr/lib/python*/site-packages/logilab/astng/test
# install tests
(cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/python-logilab-astng/usr/share/doc/python-logilab-astng/test/{} \;)
@@ -51,6 +46,8 @@ binary-indep: build install
dh_testdir
dh_testroot
dh_install -i
+ dh_pycentral -i
+ dh_python -i
gzip -9 -c ChangeLog > changelog.gz
dh_installchangelogs -i
dh_installexamples -i
@@ -64,8 +61,8 @@ binary-indep: build install
dh_md5sums -i
dh_builddeb -i
-
+binary-arch:
binary: binary-indep
-.PHONY: build clean binary binary-indep
+.PHONY: build clean binary binary-indep binary-arch