summaryrefslogtreecommitdiff
path: root/debian.sid
diff options
context:
space:
mode:
authorJulien Jehannet <julien.jehannet@logilab.fr>2011-10-20 12:09:45 +0200
committerJulien Jehannet <julien.jehannet@logilab.fr>2011-10-20 12:09:45 +0200
commit9c021bae3017b086ddbbe34c79b0eb87a61b56e7 (patch)
treeb95ab5d0862e0e38b515a94b24be59b859504c67 /debian.sid
parent3684fa493e173c89f23fcea4059fef59930034ac (diff)
downloadastroid-9c021bae3017b086ddbbe34c79b0eb87a61b56e7.tar.gz
[py3k] make python3 package available in sid (closes: #81139)
Forget hardy distribution.
Diffstat (limited to 'debian.sid')
-rw-r--r--debian.sid/control39
-rwxr-xr-xdebian.sid/rules42
-rw-r--r--debian.sid/source/format1
3 files changed, 82 insertions, 0 deletions
diff --git a/debian.sid/control b/debian.sid/control
new file mode 100644
index 0000000..c73a764
--- /dev/null
+++ b/debian.sid/control
@@ -0,0 +1,39 @@
+Source: logilab-astng
+Section: python
+Priority: optional
+Maintainer: Logilab S.A. <contact@logilab.fr>
+Uploaders: Sylvain Thénault <sylvain.thenault@logilab.fr>,
+ Alexandre Fayolle <afayolle@debian.org>,
+ Sandro Tosi <morph@debian.org>,
+ Julien Jehannet <julien.jehannet@logilab.fr>
+Build-Depends: debhelper (>= 7.0.50~), python-all, python3-all
+Standards-Version: 3.9.2
+Homepage: http://www.logilab.org/project/logilab-astng
+Vcs-Hg: http://hg.logilab.org/logilab/astng
+Vcs-Browser: http://hg.logilab.org/logilab/astng
+
+Package: python-logilab-astng
+Architecture: all
+Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common
+Description: rebuild a new abstract syntax tree from Python's ast
+ The aim of this module is to provide a common base representation of
+ Python source code for projects such as pyreverse or pylint.
+ .
+ It rebuilds the tree generated by the _ast module by recursively walking down
+ the AST and building an extended ast (let's call it astng ;). The new node
+ classes have additional methods and attributes for different usages.
+ Furthermore, astng builds partial trees by inspecting living objects.
+
+Package: python3-logilab-astng
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}, python3-logilab-common
+Description: rebuild a new abstract syntax tree from Python's ast
+ The aim of this module is to provide a common base representation of
+ Python source code for projects such as pyreverse or pylint.
+ .
+ It rebuilds the tree generated by the _ast module by recursively walking down
+ the AST and building an extended ast (let's call it astng ;). The new node
+ classes have additional methods and attributes for different usages.
+ Furthermore, astng builds partial trees by inspecting living objects.
+
+
diff --git a/debian.sid/rules b/debian.sid/rules
new file mode 100755
index 0000000..1a9c55b
--- /dev/null
+++ b/debian.sid/rules
@@ -0,0 +1,42 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+#
+# adapted by Logilab for automatic generation by debianize
+# (part of the devtools project, http://www.logilab.org/projects/devtools)
+#
+# Copyright (c) 2003-2011 LOGILAB S.A. (Paris, FRANCE).
+# http://www.logilab.fr/ -- mailto:contact@logilab.fr
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+include /usr/share/python/python.mk
+
+PACKAGE:=$(call py_pkgname,python-logilab-astng,python)
+PACKAGE3:=$(call py_pkgname,python-logilab-astng,python3.)
+
+%:
+ dh $@ --with python2,python3
+
+override_dh_install:
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/$(PACKAGE)/ \
+ ${py_setup_install_args}
+ NO_SETUPTOOLS=1 python3 setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/$(PACKAGE3)/ \
+ ${py_setup_install_args}
+ rm -rf debian/*/usr/lib/python*/*-packages/logilab/astng/test
+ rm -rf debian/*/usr/lib/python*/*-packages/logilab/__init__.py
+
+override_dh_installdocs:
+ dh_installdocs -i README*
+ dh_installchangelogs -i ChangeLog
+
+override_dh_compress:
+ dh_compress -i -X.py -X.ini -X.xml -Xtest/
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ # PYTHON 2.X + PYTHON 3.2
+endif
diff --git a/debian.sid/source/format b/debian.sid/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian.sid/source/format
@@ -0,0 +1 @@
+3.0 (quilt)