summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAlexandre Fayolle <alexandre.fayolle@logilab.fr>2009-07-02 10:11:34 +0200
committerAlexandre Fayolle <alexandre.fayolle@logilab.fr>2009-07-02 10:11:34 +0200
commit63847a83d8c20bef613a04748180fc1cbde9625b (patch)
tree884f0e84f1ad6dd653b3b641f2b8d5b934800b87 /debian
parent3a218c41df6879485f2f4f9525962e40b257a0d7 (diff)
downloadastroid-63847a83d8c20bef613a04748180fc1cbde9625b.tar.gz
backported Debian packaging updates
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog30
-rw-r--r--debian/control15
-rw-r--r--debian/copyright7
-rwxr-xr-xdebian/rules11
4 files changed, 50 insertions, 13 deletions
diff --git a/debian/changelog b/debian/changelog
index 63c67ac..b1f3b7d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,33 @@
+logilab-astng (0.19.0-2) unstable; urgency=medium
+
+ [ Sandro Tosi ]
+ * debian/python-logilab-astng.preinst
+ - added to remove leftover files after migration to python-support; thanks
+ to Helmut Grohne and Yaroslav Halchenko for the reports; Closes: #533282,
+ #528458
+ * urgency=medium because it fixes RC bugs
+ * debian/control
+ - bump Standards-Version 3.8.2 (no changes needed)
+ * debian/copyright
+ - bump upstream copyright years
+ - added packaging copyright for the work I do
+ * debian/control
+ - updated long description to match new upstream one
+ - bump python-logilab-common dependency to at least 0.39.0
+ * debian/rules
+ - using --root instead of --prefix
+
+
+ [ Julien Lavergne ]
+ * debian/{control, rules}
+ - prepare for the upcoming Python 2.6 transition; thanks to Alessio Treglia
+ for the report and patch; Closes: #530607
+ + added versioned depend on python and debhelper to have functions we need
+ + used --install-layout=deb to setup.py install
+ + replaced site-packages by *-packages
+
+ -- Sandro Tosi <morph@debian.org> Thu, 18 Jun 2009 07:14:21 +0200
+
logilab-astng (0.19.0-1) unstable; urgency=low
* actually backport Sandro Tosi 0.17.4-2 changes which wasn't in 0.18.0-1
diff --git a/debian/control b/debian/control
index 311e487..23288ee 100644
--- a/debian/control
+++ b/debian/control
@@ -3,10 +3,10 @@ Section: python
Priority: optional
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders: Sylvain Thénault <sylvain.thenault@logilab.fr>, Alexandre Fayolle <afayolle@debian.org>, Sandro Tosi <morph@debian.org>
-Build-Depends: debhelper (>= 5.0.37.2), python (>= 2.3.5-7)
+Build-Depends: debhelper (>= 5.0.37.2), python (>= 2.4)
Build-Depends-Indep: python-support
XS-Python-Version: all
-Standards-Version: 3.8.1
+Standards-Version: 3.8.2
Homepage: http://www.logilab.org/project/logilab-astng
Vcs-Svn: svn://svn.debian.org/svn/python-modules/packages/logilab-astng/trunk/
Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/logilab-astng/trunk/
@@ -19,8 +19,9 @@ Description: extend Python's abstract syntax tree (AST)
The aim of this module is to provide a common base representation of
Python source code for projects such as pyreverse or pylint.
.
- It extends classes defined in the compiler.ast module with some
- additional methods and attributes. Instance attributes are added by a
- builder object, which can either generate extended ast (let's call
- them astng ;) by visiting an existant ast tree or by inspecting
- living object. Methods are added by monkey patching ast classes.
+ It extends classes defined in the compiler.ast module (Python <= 2.4)
+ or in the builtin _ast module (Python >= 2.5) with some additional
+ methods and attributes. Instance attributes are added by a builder
+ object, which can either generate extended ast (let's call them astng
+ ;) by visiting an existant ast tree or by inspecting living
+ object. Methods are added by monkey patching ast classes.
diff --git a/debian/copyright b/debian/copyright
index 0505c9c..7e26590 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -8,9 +8,9 @@ Upstream Author:
Copyright:
- Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
+ Copyright (c) 2003-2009 LOGILAB S.A. (Paris, FRANCE).
http://www.logilab.fr/ -- mailto:contact@logilab.fr
- Copyright (C) 2003-2008 Sylvain Thenault
+ Copyright (C) 2003-2009 Sylvain Thenault
License:
@@ -31,3 +31,6 @@ License:
On Debian systems, the complete text of the GNU General Public License
v2 may be found in '/usr/share/common-licenses/GPL-2'.
+
+The Debian packaging is Copyright (C) 2008-2009, Sandro Tosi <morph@debian.org>
+and is licensed under the same terms as upstream code (see above).
diff --git a/debian/rules b/debian/rules
index 883691f..f05039e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,7 +26,8 @@ clean:
NO_SETUPTOOLS=1 python setup.py clean
find . -name "*.pyc" -delete
- rm -rf build
+
+ rm -rf build
dh_clean build-stamp
install: build
@@ -35,12 +36,14 @@ install: build
dh_clean -k
dh_installdirs
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile --prefix=debian/python-logilab-astng/usr/
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/python-logilab-astng/ \
+ --install-layout=deb
# remove sub-package __init__ file (created in postinst)
- rm debian/python-logilab-astng/usr/lib/python*/site-packages/logilab/__init__.py
+ rm debian/python-logilab-astng/usr/lib/python*/*-packages/logilab/__init__.py
# remove test directory (installed in a separated package)
- rm -rf debian/python-logilab-astng/usr/lib/python*/site-packages/logilab/astng/test
+ rm -rf debian/python-logilab-astng/usr/lib/python*/*-packages/logilab/astng/test
# install tests
(cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/python-logilab-astng/usr/share/doc/python-logilab-astng/test/{} \;)