summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorsylvain thenault <sylvain.thenault@logilab.fr>2009-03-24 15:14:25 +0100
committersylvain thenault <sylvain.thenault@logilab.fr>2009-03-24 15:14:25 +0100
commit801163a5e9b0e4b04e14f6aaad506f7b0b582c5c (patch)
treee70e53eb28e0fbb4d5a5d4f792d2b8567ad9f21f /debian
parent7004d538c18e79001a5644c7b20318d6bd768fdc (diff)
downloadastroid-801163a5e9b0e4b04e14f6aaad506f7b0b582c5c.tar.gz
setuptools fix
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index ea2fae8..5efafb0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,7 +15,7 @@ build: build-stamp
build-stamp:
dh_testdir
- python setup.py -q build
+ NO_SETUPTOOLS=1 python setup.py -q build
touch build-stamp
@@ -23,7 +23,7 @@ clean:
dh_testdir
dh_testroot
- python setup.py clean
+ NO_SETUPTOOLS=1 python setup.py clean
find . -name "*.pyc" -delete
@@ -35,7 +35,7 @@ install: build
dh_clean -k
dh_installdirs
- python setup.py -q install --no-compile --prefix=debian/python-logilab-astng/usr/
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile --prefix=debian/python-logilab-astng/usr/
# remove sub-package __init__ file (created in postinst)
rm debian/python-logilab-astng/usr/lib/python*/site-packages/logilab/__init__.py