summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2010-04-28 10:35:32 +0200
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2010-04-28 10:35:32 +0200
commit2d4587c552493fae8a298d746c0ed184a095cab5 (patch)
tree43fa8b1664106e29bccb3d636f5f68b2d5763610 /setup.py
parent4afb808bf23d5fccb323e020f10c11dbf9d1948e (diff)
downloadastroid-2d4587c552493fae8a298d746c0ed184a095cab5.tar.gz
proper licensing information (LGPL-2.1). Hope I get it right this time.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 19 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 5d2a2cc..2220510 100644
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,26 @@
#!/usr/bin/env python
# pylint: disable-msg=W0404,W0622,W0704,W0613,W0152
+# copyright 2003-2010 LOGILAB S.A. (Paris, FRANCE), all rights reserved.
+# contact http://www.logilab.fr/ -- mailto:contact@logilab.fr
+# copyright 2003-2010 Sylvain Thenault, all rights reserved.
+# contact mailto:thenault@gmail.com
+#
+# This file is part of logilab-astng.
+#
+# logilab-astng is free software: you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by the
+# Free Software Foundation, either version 2.1 of the License, or (at your
+# option) any later version.
+#
+# logilab-astng is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License
+# for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License along
+# with logilab-astng. If not, see <http://www.gnu.org/licenses/>.
"""Generic Setup script, takes package info from __pkginfo__.py file.
-:copyright: 2003-2010 LOGILAB S.A. (Paris, FRANCE), all rights reserved.
-:contact: http://www.logilab.fr/ -- mailto:contact@logilab.fr
-:license: Lesser General Public License version 2 - http://www.gnu.org/licenses
"""
__docformat__ = "restructuredtext en"