summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTorsten Marek <shlomme@gmail.com>2014-11-08 23:58:19 +0100
committerTorsten Marek <shlomme@gmail.com>2014-11-08 23:58:19 +0100
commit4553dacea8be3fa9f217e1b5e755caa6e10e0cd3 (patch)
treea036ca37dd514cd3a4a1e4022440fddb45b27fde /setup.py
parent0c7327e7599c69843ffdb884d313863ec36cb6dd (diff)
downloadastroid-4553dacea8be3fa9f217e1b5e755caa6e10e0cd3.tar.gz
Do not import the astroid package when running setup, evaluate __pkginfo__ directly.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index bd5be28..d356110 100644
--- a/setup.py
+++ b/setup.py
@@ -19,9 +19,11 @@
# with astroid. If not, see <http://www.gnu.org/licenses/>.
"""Setup script for astroid."""
from setuptools import setup, find_packages
-from astroid import __pkginfo__
-from astroid.__pkginfo__ import modname, version, license, description, \
- web, author, author_email, distname, install_requires, classifiers
+
+pkginfo = 'astroid/__pkginfo__.py'
+
+with open(pkginfo, 'rb') as fobj:
+ exec(compile(fobj.read(), pkginfo, 'exec'), locals())
with open('README') as fobj:
long_description = fobj.read()