summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTorsten Marek <shlomme@gmail.com>2014-11-06 23:00:44 +0100
committerTorsten Marek <shlomme@gmail.com>2014-11-06 23:00:44 +0100
commita78ddfa026d67f8387c935db5fe9951179cbd0ab (patch)
tree2c43e04ffa50bdac05ce61d5c522a0eafaaa2e7b /setup.py
parentf76823c9ac50ff97365922a99c9a05797219fdb6 (diff)
downloadastroid-a78ddfa026d67f8387c935db5fe9951179cbd0ab.tar.gz
Convert the unittests to run directly with Python 3, and stop running 2to3 on install.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index a117315..0755656 100644
--- a/setup.py
+++ b/setup.py
@@ -131,20 +131,12 @@ class MyBuildPy(build_py):
dest = join(basedir, directory)
shutil.rmtree(dest, ignore_errors=True)
shutil.copytree(directory, dest)
- if sys.version_info >= (3, 0):
- # process manually python file in include_dirs (test data)
- from distutils.util import run_2to3
- print('running 2to3 on', dest)
- run_2to3([dest])
def install(**kwargs):
"""setup entry point"""
if USE_SETUPTOOLS:
if '--force-manifest' in sys.argv:
sys.argv.remove('--force-manifest')
- # install-layout option was introduced in 2.5.3-1~exp1
- elif sys.version_info < (2, 5, 4) and '--install-layout=deb' in sys.argv:
- sys.argv.remove('--install-layout=deb')
if subpackage_of:
package = subpackage_of + '.' + modname
kwargs['package_dir'] = {package : '.'}