summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog111
-rw-r--r--__pkginfo__.py2
-rw-r--r--debian/changelog6
3 files changed, 87 insertions, 32 deletions
diff --git a/ChangeLog b/ChangeLog
index 1980519..f0abc7c 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,128 +1,172 @@
Change log for the astng package
================================
- --
+2008-11-19 -- 0.17.4
* fix #6015: filter statements bug triggering W0631 false positive in pylint
+
* fix #5571: Function.is_method() should return False on module level
functions decorated by staticmethod/classmethod (avoid some crash in pylint)
+
* fix #5010: understand python 2.5 explicit relative imports
-
+
+
+
2008-09-10 -- 0.17.3
* fix #5889: astng crash on certain pyreverse projects
+
* fix bug w/ loop assigment in .lookup
+
* apply Maarten patch fixing a crash on TryFinalaly.block_range and fixing
'else'/'final' block line detection
-
+
+
+
2008-01-14 -- 0.17.2
* "with" statement support, patch provided by Brian Hawthorne
+
* fixed recursion arguments in nodes_of_class method as notified by
Dave Borowitz
+
* new InstanceMethod node introduced to wrap bound method (eg Function
node), patch provided by Dave Borowitz
-
+
+
+
2007-06-07 -- 0.17.1
* fix #3651: crash when callable as defaut arg
+
* fix #3670: subscription inference crash in some cases
+
* fix #3673: Lambda instance has no attribute 'pytype'
+
* fix crash with chained "import as"
+
* fix crash on numpy
+
* fix potential InfiniteRecursion error with builtin objects
+
* include patch from Marien Zwart fixing some test / py 2.5
+
* be more error resilient when accessing living objects from external
code in the manager
-
+
+
+
2007-02-22 -- 0.17.0
* api change to be able to infer using a context (used to infer function call
result only for now)
+
* slightly better inference on astng built from living object by trying to infer
dummy nodes (able to infer 'help' builtin for instance)
+
* external attribute definition support
+
* basic math operation inference
+
* new pytype method on possibly infered node (eg module, classes, const...)
+
* fix a living object astng building bug, which was making "open" uninferable
+
* fix lookup of name in method bug (#3289)
+
* fix decorator lookup bug (#3261)
-
+
+
2006-11-23 -- 0.16.3
* enhance inference for the subscription notation (motivated by a patch from Amaury)
and for unary sub/add
-
+
+
+
2006-11-15 -- 0.16.2
* grrr, fixed python 2.3 incompatibility introduced by generator expression
scope handling
+
* upgrade to avoid warnings with logilab-common 0.21.0 (on which now
depends so)
+
* backported astutils module from logilab-common
+
+
2006-09-25 -- 0.16.1
* python 2.5 support, patch provided by Marien Zwart
+
* fix [Class|Module].block_range method (this fixes pylint's inline
disabling of messages on classes/modules)
+
* handle class.__bases__ and class.__mro__ (proper metaclass handling
still needed though)
+
* drop python2.2 support: remove code that was working around python2.2
+
* fixed generator expression scope bug
+
* patch transformer to extract correct line information
-
-
+
+
+
2006-04-19 -- 0.16.0
* fix living object building to consider classes such as property as
a class instead of a data descriptor
-
+
* fix multiple assignment inference which was discarding some solutions
-
+
* added some line manipulation methods to handle pylint's block messages
control feature (Node.last_source_line(), None.block_range(lineno)
-
-
+
+
+
2006-03-10 -- 0.15.1
* fix avoiding to load everything from living objects... Thanks Amaury!
-
+
* fix a possible NameError in Instance.infer_call_result
+
2006-03-06 -- 0.15.0
* fix possible infinite recursion on global statements (close #10342)
and in various other cases...
-
+
* fix locals/globals interactions when the global statement is used
(close #10434)
* multiple inference related bug fixes
-
+
* associate List, Tuple and Dict and Const nodes to their respective
classes
-
+
* new .ass_type method on assignment related node, returning the
assigment type node (Assign, For, ListCompFor, GenExprFor,
TryExcept)
-
+
* more API refactoring... .resolve method has disappeared, now you
have .ilookup on every nodes and .getattr/.igetattr on node
supporting the attribute protocol
-
+
* introduced a YES object that may be returned when there is ambiguity
on an inference path (typically function call when we don't know
arguments value)
-
+
* builder try to instantiate builtin exceptions subclasses to get their
instance attribute
+
2006-01-10 -- 0.14.0
* some major inference improvments and refactoring ! The drawback is
the introduction of some non backward compatible change in the API
but it's imho much cleaner and powerful now :)
-
+
* new boolean property .newstyle on Class nodes (implements #10073)
-
+
* new .import_module method on Module node to help in .resolve
refactoring
-
+
* .instance_attrs has list of assignments to instance attribute
dictionary as value instead of one
-
+
* added missing GenExprIf and GenExprInner nodes, and implements
as_string for each generator expression related nodes
@@ -135,15 +179,16 @@ Change log for the astng package
* fix a bug regarding construction of Function node from living object
with realier version of python 2.4
-
+
* fix a NameError on Import and From self_resolve method
* fix a bug occuring when building an astng from a living object with
a property
-
+
* lint fixes
+
2005-11-07 -- 0.13.1
* fix bug on building from living module the same object in
encountered more than once time (eg builtins.object) (close #10069)
@@ -154,7 +199,7 @@ Change log for the astng package
precedence over module (close #10066)
* locals dict for package contains __path__ definition (close #10065)
-
+
* astng provide GenExpr and GenExprFor nodes with python >= 2.4
(close #10063)
@@ -167,7 +212,8 @@ Change log for the astng package
* normalize parser.ParserError to SyntaxError with python 2.2
-
+
+
2005-10-21 -- 0.13.0
* .locals and .globals on scoped node handle now a list of references
to each assigment statements instead of a single reference to the
@@ -175,15 +221,18 @@ Change log for the astng package
* fix bug with manager.astng_from_module_name when a context file is
given (notably fix ZODB 3.4 crash with pylint/pyreverse)
-
+
* fix Compare.as_string method
-
+
* fix bug with lambda object missing the "type" attribute
* some minor refactoring
-
+
* This package has been extracted from the logilab-common package, which
will be kept for some time for backward compatibility but will no
longer be maintained (this explains that this package is starting with
the 0.13 version number, since the fork occurs with the version
released in logilab-common 0.12).
+
+
+
diff --git a/__pkginfo__.py b/__pkginfo__.py
index 89d72aa..20a3222 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -21,7 +21,7 @@ logilab.astng packaging information
modname = 'astng'
distname = 'logilab-astng'
-numversion = (0, 17, 3)
+numversion = (0, 17, 4)
version = '.'.join([str(num) for num in numversion])
pyversions = ["2.3", "2.4", "2.5"]
diff --git a/debian/changelog b/debian/changelog
index cc057d3..8c7ccd4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+logilab-astng (0.17.4-1) unstable; urgency=low
+
+ * new upstream release
+
+ -- Sylvain Thénault <sylvain.thenault@logilab.fr> Wed, 19 Nov 2008 15:16:37 +0100
+
logilab-astng (0.17.3-1) unstable; urgency=low
* new upstream release