summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonard Richardson <leonardr@segfault.org>2017-01-02 10:01:14 -0500
committerLeonard Richardson <leonardr@segfault.org>2017-01-02 10:01:14 -0500
commit8d6a43cb5a31fa4fe632b603ebd7c50f514e1073 (patch)
treea6baedc6309d2b60d02459faf0cdbdc241b33fab
parent4f0ef4f533038c7f67b1b9a77147cc402c707a25 (diff)
downloadbeautifulsoup4-8d6a43cb5a31fa4fe632b603ebd7c50f514e1073.tar.gz
I need to do another release because of an error while running the release script.
-rw-r--r--NEWS.txt10
-rw-r--r--bs4/__init__.py2
-rw-r--r--prepare-release.sh6
-rw-r--r--setup.py2
4 files changed, 13 insertions, 7 deletions
diff --git a/NEWS.txt b/NEWS.txt
index 80967ab..e88dd68 100644
--- a/NEWS.txt
+++ b/NEWS.txt
@@ -1,11 +1,17 @@
-= 4.5.2 (20170102) =
+= 4.5.3 (20170102) =
* Fixed foster parenting when html5lib is the tree builder. Thanks to
Geoffrey Sneddon for a patch and test.
-
+
* Fixed yet another problem that caused the html5lib tree builder to
create a disconnected parse tree. [bug=1629825]
+= 4.5.2 (20170102) =
+
+* Apart from the version number, this release is identical to
+ 4.5.3. Due to user error, it could not be completely uploaded to
+ PyPI. Use 4.5.3 instead.
+
= 4.5.1 (20160802) =
* Fixed a crash when passing Unicode markup that contained a
diff --git a/bs4/__init__.py b/bs4/__init__.py
index 94be093..46caac0 100644
--- a/bs4/__init__.py
+++ b/bs4/__init__.py
@@ -21,7 +21,7 @@ http://www.crummy.com/software/BeautifulSoup/bs4/doc/
# found in the LICENSE file.
__author__ = "Leonard Richardson (leonardr@segfault.org)"
-__version__ = "4.5.2"
+__version__ = "4.5.3"
__copyright__ = "Copyright (c) 2004-2017 Leonard Richardson"
__license__ = "MIT"
diff --git a/prepare-release.sh b/prepare-release.sh
index aaa95a5..d88ff1e 100644
--- a/prepare-release.sh
+++ b/prepare-release.sh
@@ -102,8 +102,8 @@ rm -rf ../py3-install-test-virtualenv
Do the release for real.
# Register the project and upload the source distribution and Python 2 wheel.
-python setup.py register -r test
-python setup.py sdist bdist_wheel upload -r test
+python setup.py register
+python setup.py sdist bdist_wheel upload
# Create a Python 3 environment and install Beautiful Soup
# from the source distribution that was just uploaded
@@ -118,7 +118,7 @@ echo "EXPECT HTML ON LINE BELOW"
# Create and upload a Python 3 wheel from within a virtual environment
# that has the Python 3 version of the code.
pip install wheel
-python3 setup.py bdist_wheel upload -r test
+python3 setup.py bdist_wheel upload
# Remove the Python 3 virtual environment.
deactivate
diff --git a/setup.py b/setup.py
index 06551f9..89c9661 100644
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ from setuptools import (
setup(
name="beautifulsoup4",
- version = "4.5.2",
+ version = "4.5.3",
author="Leonard Richardson",
author_email='leonardr@segfault.org',
url="http://www.crummy.com/software/BeautifulSoup/bs4/",