summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVille Skyttä <ville.skytta@iki.fi>2016-07-26 19:50:21 +0300
committerVille Skyttä <ville.skytta@iki.fi>2016-07-26 19:50:21 +0300
commit922d580ff2bc44dc3e498b9c53b2530ec2bd76b9 (patch)
tree5b4e313ed4e5d235617be5e4b5b0488aa2da60e9
parent99821550d79bb4524f31f153a53a10a069bafccb (diff)
downloadbeautifulsoup4-922d580ff2bc44dc3e498b9c53b2530ec2bd76b9.tar.gz
Clarify Python 2(.7) support status
-rw-r--r--bs4/__init__.py2
-rw-r--r--bs4/tests/test_soup.py3
-rw-r--r--setup.py2
3 files changed, 3 insertions, 4 deletions
diff --git a/bs4/__init__.py b/bs4/__init__.py
index 308428a..aff8fc3 100644
--- a/bs4/__init__.py
+++ b/bs4/__init__.py
@@ -8,7 +8,7 @@ Beautiful Soup uses a pluggable XML or HTML parser to parse a
provides methods and Pythonic idioms that make it easy to navigate,
search, and modify the parse tree.
-Beautiful Soup works with Python 2.6 and up. It works better if lxml
+Beautiful Soup works with Python 2.7 and up. It works better if lxml
and/or html5lib is installed.
For more than you ever wanted to know about Beautiful Soup, see the
diff --git a/bs4/tests/test_soup.py b/bs4/tests/test_soup.py
index e1c2f3d..4748214 100644
--- a/bs4/tests/test_soup.py
+++ b/bs4/tests/test_soup.py
@@ -35,7 +35,6 @@ try:
except ImportError, e:
LXML_PRESENT = False
-PYTHON_2_PRE_2_7 = (sys.version_info < (2,7))
PYTHON_3_PRE_3_2 = (sys.version_info[0] == 3 and sys.version_info < (3,2))
class TestConstructor(SoupTest):
@@ -279,7 +278,7 @@ class TestEncodingConversion(SoupTest):
self.assertEqual(soup_from_unicode.encode('utf-8'), self.utf8_data)
@skipIf(
- PYTHON_2_PRE_2_7 or PYTHON_3_PRE_3_2,
+ PYTHON_3_PRE_3_2,
"Bad HTMLParser detected; skipping test of non-ASCII characters in attribute name.")
def test_attribute_name_containing_unicode_characters(self):
markup = u'<div><a \N{SNOWMAN}="snowman"></a></div>'
diff --git a/setup.py b/setup.py
index 2952547..a1e42bb 100644
--- a/setup.py
+++ b/setup.py
@@ -23,7 +23,7 @@ setup(
"Intended Audience :: Developers",
"License :: OSI Approved :: MIT License",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
'Programming Language :: Python :: 3',
"Topic :: Text Processing :: Markup :: HTML",
"Topic :: Text Processing :: Markup :: XML",