summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLeonard Richardson <leonard.richardson@canonical.com>2012-02-08 09:21:39 -0500
committerLeonard Richardson <leonard.richardson@canonical.com>2012-02-08 09:21:39 -0500
commitfc747a7b7f4b71bf38a8fb4ce74e174f19d2fb63 (patch)
tree7cc5b85d29773504be0f9cae9a0c4384bdf603a0 /setup.py
parent8b908fa7884fa1c769e54b164eeb85a6e2352977 (diff)
downloadbeautifulsoup4-fc747a7b7f4b71bf38a8fb4ce74e174f19d2fb63.tar.gz
Moved around a bunch of metadata.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 15 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 7fce6b0..4eebcb8 100644
--- a/setup.py
+++ b/setup.py
@@ -7,16 +7,21 @@ except ImportError:
from distutils.command.build_py import build_py
setup(name="beautifulsoup4",
- version = "4.0.0b4",
- author="Leonard Richardson",
- author_email='leonardr@segfault.org',
- url="http://www.crummy.com/software/BeautifulSoup/bs4/",
- download_url = "http://www.crummy.com/software/BeautifulSoup/bs4/download/",
- long_description="""Beautiful Soup sits atop an HTML or XML parser, providing Pythonic idioms for iterating, searching, and modifying the parse tree.""",
- license="MIT",
- packages=['bs4', 'bs4.builder', 'bs4.tests'],
- package_data={"bs4": ["doc/source/*.jpg", "doc/source/*.rst", "doc/source/*.py", "doc/Makefile"]},
- cmdclass = {'build_py':build_py},
+ version = "4.0.0b4",
+ author="Leonard Richardson",
+ author_email='leonardr@segfault.org',
+ url="http://www.crummy.com/software/BeautifulSoup/bs4/",
+ download_url = "http://www.crummy.com/software/BeautifulSoup/bs4/download/",
+ long_description="""Beautiful Soup sits atop an HTML or XML parser, providing Pythonic idioms for iterating, searching, and modifying the parse tree.""",
+ license="MIT",
+ packages=['bs4', 'bs4.builder', 'bs4.tests'],
+ package_data={
+ "bs4": ["doc/source/*.jpg", "doc/source/*.rst",
+ "doc/source/*.py", "doc/Makefile"]
+ },
+ data_files=[
+ ('', ['COPYING.txt', 'NEWS.txt', 'AUTHORS.txt', 'README.txt'])],
+ cmdclass = {'build_py':build_py},
classifiers=["Development Status :: 4 - Beta",
"Intended Audience :: Developers",
"License :: OSI Approved :: MIT License",