summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--NEWS.txt2
-rw-r--r--TODO.txt2
-rw-r--r--bs4/__init__.py15
-rw-r--r--bs4/doc/source/index.rst5
-rw-r--r--setup.py2
5 files changed, 14 insertions, 12 deletions
diff --git a/NEWS.txt b/NEWS.txt
index d77b95b..cd28490 100644
--- a/NEWS.txt
+++ b/NEWS.txt
@@ -1,4 +1,4 @@
-= 4.0.0b6 () =
+= 4.0.0b6 (20110216) =
* The value of multi-valued attributes like "class" are always turned
into a list, even if there's only one value.
diff --git a/TODO.txt b/TODO.txt
index 2f03dd2..8b239b1 100644
--- a/TODO.txt
+++ b/TODO.txt
@@ -1,6 +1,8 @@
Bugs
----
+* Issue a DataLossWarning if Unicode, Dammit replaces characters.
+
* I think whitespace may not be processed correctly.
* html5lib doesn't support SoupStrainers, which is OK, but there
diff --git a/bs4/__init__.py b/bs4/__init__.py
index 1aaa6dd..98ac57b 100644
--- a/bs4/__init__.py
+++ b/bs4/__init__.py
@@ -3,22 +3,21 @@ Elixir and Tonic
"The Screen-Scraper's Friend"
http://www.crummy.com/software/BeautifulSoup/
-Beautiful Soup uses a plug-in parser to parse a (possibly invalid) XML
-or HTML document into a tree representation. The parser does the work
-of building a parse tree, and Beautiful Soup provides provides methods
-and Pythonic idioms that make it easy to navigate, search, and modify
-the parse tree.
+Beautiful Soup uses a pluggable XML or HTML parser to parse a
+(possibly invalid) document into a tree representation. Beautiful Soup
+provides provides methods and Pythonic idioms that make it easy to
+navigate, search, and modify the parse tree.
Beautiful Soup works with Python 2.6 and up. It works better if lxml
-or html5lib is installed.
+and/or html5lib is installed.
For more than you ever wanted to know about Beautiful Soup, see the
documentation:
-http://www.crummy.com/software/BeautifulSoup/documentation.html
+http://www.crummy.com/software/BeautifulSoup/bs4/doc/
"""
__author__ = "Leonard Richardson (leonardr@segfault.org)"
-__version__ = "4.0.0b5"
+__version__ = "4.0.0b6"
__copyright__ = "Copyright (c) 2004-2012 Leonard Richardson"
__license__ = "MIT"
diff --git a/bs4/doc/source/index.rst b/bs4/doc/source/index.rst
index 8b7f1e4..8328ed7 100644
--- a/bs4/doc/source/index.rst
+++ b/bs4/doc/source/index.rst
@@ -2503,8 +2503,9 @@ Miscellaneous
contains a single tag B and nothing else, then A.string is the same as
B.string. (Previously, it was None.)
-`Multi-valued attributes`_ like ``class`` are presented as lists. This
-may affect the way you search by CSS class.
+`Multi-valued attributes`_ like ``class`` have lists of strings as
+their values, not strings. This may affect the way you search by CSS
+class.
If you pass one of the ``find*`` methods both :ref:`text <text>` `and`
a tag-specific argument like :ref:`name <name>`, Beautiful Soup will
diff --git a/setup.py b/setup.py
index 407559d..d033def 100644
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,7 @@ except ImportError:
from distutils.command.build_py import build_py
setup(name="beautifulsoup4",
- version = "4.0.0b5",
+ version = "4.0.0b6",
author="Leonard Richardson",
author_email='leonardr@segfault.org',
url="http://www.crummy.com/software/BeautifulSoup/bs4/",