summaryrefslogtreecommitdiff
path: root/prepare-release.sh
diff options
context:
space:
mode:
Diffstat (limited to 'prepare-release.sh')
-rw-r--r--prepare-release.sh34
1 files changed, 18 insertions, 16 deletions
diff --git a/prepare-release.sh b/prepare-release.sh
index c278b67..ff3f6c0 100644
--- a/prepare-release.sh
+++ b/prepare-release.sh
@@ -17,7 +17,7 @@ rm -rf build dist
python setup.py sdist bdist_wheel
# Upload the 2.x source distro and wheel to pypi test
-python setup.py register -r test
+# python setup.py register -r test
python setup.py sdist bdist_wheel upload -r test
# Try 2.x install from pypi test
@@ -35,7 +35,7 @@ rm -rf ../py2-install-test-virtualenv
rm -rf ../py3-source-install
virtualenv -p /usr/bin/python3 ../py3-source-install
source ../py3-source-install/bin/activate
-pip install -i https://testpypi.python.org/pypi beautifulsoup4
+pip3 install -i https://testpypi.python.org/pypi beautifulsoup4
echo "EXPECT HTML ON LINE BELOW"
(cd .. && python -c "from bs4 import _s; print(_s('<a>foo', 'html.parser'))")
# That should print '<a>foo</a>'
@@ -90,8 +90,8 @@ echo
rm -rf ../py3-install-test-virtualenv
virtualenv -p /usr/bin/python3 ../py3-install-test-virtualenv
source ../py3-install-test-virtualenv/bin/activate
-pip install --upgrade setuptools
-pip install dist/beautifulsoup4-4.*-py3-none-any.whl -e .[html5lib]
+pip3 install --upgrade setuptools
+pip3 install dist/beautifulsoup4-4.*-py3-none-any.whl -e .[html5lib]
echo "EXPECT HTML ON LINE BELOW"
(cd .. && python -c "from bs4 import _s; print(_s('<a>foo', 'html5lib'))")
# That should print '<html><head></head><body><a>foo</a></body></html>'
@@ -102,28 +102,30 @@ rm -rf ../py3-install-test-virtualenv
Do the release for real.
+twine upload dist/*
+
# Register the project and upload the source distribution and Python 2 wheel.
-python setup.py register
-python setup.py sdist bdist_wheel upload
+# python setup.py register
+# python setup.py sdist bdist_wheel upload
# Create a Python 3 environment and install Beautiful Soup
# from the source distribution that was just uploaded
-rm -rf ../py3-source-install
-virtualenv -p /usr/bin/python3 ../py3-source-install
-source ../py3-source-install/bin/activate
-pip install -i https://pypi.python.org/pypi beautifulsoup4
-echo "EXPECT HTML ON LINE BELOW"
-(cd .. && python -c "from bs4 import _s; print(_s('<a>foo', 'html.parser'))")
+#rm -rf ../py3-source-install
+#virtualenv -p /usr/bin/python3 ../py3-source-install
+#source ../py3-source-install/bin/activate
+#pip install -i https://pypi.python.org/pypi beautifulsoup4
+#echo "EXPECT HTML ON LINE BELOW"
+#(cd .. && python -c "from bs4 import _s; print(_s('<a>foo', 'html.parser'))")
# That should print '<a>foo</a>'
# Create and upload a Python 3 wheel from within a virtual environment
# that has the Python 3 version of the code.
-pip install wheel
-python3 setup.py bdist_wheel upload
+#pip install wheel
+#python3 setup.py bdist_wheel upload
# Remove the Python 3 virtual environment.
-deactivate
-rm -rf ../py3-source-install
+#deactivate
+#rm -rf ../py3-source-install
################