summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorErik Rose <erik@mozilla.com>2011-11-07 01:53:27 -0800
committerErik Rose <erik@mozilla.com>2011-11-07 01:53:27 -0800
commit8c7940f196b111742adbcf50caddb62cb78d3497 (patch)
tree17e25f0c5f61337cb2a51bf2e9e0944102cd0a47 /setup.py
downloadblessings-8c7940f196b111742adbcf50caddb62cb78d3497.tar.gz
Here's Terminator 1.0, lifted out of nose-progressive.terminator-1.0
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py32
1 files changed, 32 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..c0490fc
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,32 @@
+import sys
+
+from setuptools import setup, find_packages
+
+
+extra_setup = {}
+if sys.version_info >= (3,):
+ extra_setup['use_2to3'] = True
+
+setup(
+ name='terminator',
+ version='1.0',
+ description='A thin, practical wrapper around terminal capabilities',
+ long_description=open('README.rst').read(),
+ author='Erik Rose',
+ author_email='erikrose@grinchcentral.com',
+ license='GPL',
+ packages=find_packages(exclude=['ez_setup']),
+ tests_require=['Nose'],
+ url='http://pypi.python.org/pypi/terminator/',
+ include_package_data=True,
+ classifiers = [
+ 'Intended Audience :: Developers',
+ 'Natural Language :: English',
+ 'Environment :: Console',
+ 'Operating System :: POSIX',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: Software Development :: User Interfaces',
+ 'Topic :: Terminals'
+ ],
+ **extra_setup
+)