summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml18
1 files changed, 18 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..f581b3f
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,18 @@
+language: python
+
+python:
+ - 2.5
+ - 2.6
+ - 2.7
+ - 3.2
+ - pypy
+
+matrix:
+ allow_failures:
+ - python: 3.2
+ - python: pypy
+
+script:
+ - pip install -q --use-mirrors nose
+ - python setup.py install
+ - nosetests -w /tmp blessings.tests