summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorjason kirtland <jek@discorporate.us>2010-02-26 17:36:02 -0800
committerjason kirtland <jek@discorporate.us>2010-02-26 17:36:02 -0800
commit5709e76abf5b55fcd54547a3774e885cb888f41f (patch)
tree59b8d27914bed9a2b86bf7edbfc8a24617d22619 /docs
parentdbd6e5568a429c6e6f5ecd417c683feac34757fe (diff)
downloadblinker-5709e76abf5b55fcd54547a3774e885cb888f41f.tar.gz
Adapted to new pickleless website doc builder.
Diffstat (limited to 'docs')
-rw-r--r--docs/source/Makefile10
-rw-r--r--docs/source/conf.py15
2 files changed, 22 insertions, 3 deletions
diff --git a/docs/source/Makefile b/docs/source/Makefile
index d524eb7..78a8488 100644
--- a/docs/source/Makefile
+++ b/docs/source/Makefile
@@ -4,6 +4,7 @@
# You can set these variables from the command line.
SPHINXOPTS =
SPHINXBUILD = sphinx-build
+VERSION ?= tip
# Internal variables.
ALLSPHINXOPTS = -d ../doctrees $(SPHINXOPTS) .
@@ -20,7 +21,7 @@ help:
sdist: clean text html
clean:
- for i in doctrees html text doctest pickles; do \
+ for i in doctrees html text doctest pickles website; do \
rm -rf ../$$i; \
done
@@ -43,3 +44,10 @@ doctest:
pickles:
mkdir -p ../pickles ../doctest
$(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) ../pickles
+
+website:
+ mkdir -p ../website ../doctrees
+ $(SPHINXBUILD) -b discorporate \
+ -D html_theme=discorporate \
+ -D version=$(VERSION) \
+ $(ALLSPHINXOPTS) ../website
diff --git a/docs/source/conf.py b/docs/source/conf.py
index c4adb72..1b9e7fc 100644
--- a/docs/source/conf.py
+++ b/docs/source/conf.py
@@ -7,6 +7,7 @@
# dir.
import os
+from os import path
import sys
# If extensions (or modules to document with autodoc) are in another directory,
@@ -23,6 +24,16 @@ extensions = ['sphinx.ext.autodoc',
'sphinx.ext.doctest',
'sphinx.ext.coverage']
+html_theme_path = ['.']
+
+try:
+ import dbuilder
+except ImportError:
+ pass
+else:
+ extensions.append('dbuilder')
+ html_theme_path.append(path.join(dbuilder.__path__[0], 'theme'))
+
# Add any paths that contain templates here, relative to this directory.
templates_path = ['_templates']
@@ -44,9 +55,9 @@ copyright = u'2010, Jason Kirtland'
# built documents.
#
# The short X.Y version.
-version = '0.9'
+version = 'tip'
# The full version, including alpha/beta/rc tags.
-release = '0.9dev'
+release = 'tip'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.