summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorpgjones <philip.graham.jones@googlemail.com>2023-02-26 11:17:50 +0000
committerPhil Jones <philip.graham.jones@googlemail.com>2023-04-02 14:58:03 +0100
commitfae6164cda6c5e9af89895a22f700402fa4b5ec5 (patch)
treea82ad0c87c84c6c43955c6908f58bfd8c232f453 /pyproject.toml
parent5ed9c956aaf68a8e2defa9722109aa2c7bcf7ae1 (diff)
downloadblinker-fae6164cda6c5e9af89895a22f700402fa4b5ec5.tar.gz
Add an initial set of type hints
These focus on the public API with the private aspect omitted. This is because these are hard to type, and may not be required with modern python. However, this should still be useful if adopted for code that uses blinker.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 65e5e5d..8dd5b87 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -24,6 +24,7 @@ classifiers = [
]
requires-python = ">= 3.7"
dynamic = ["version"]
+dependencies = ["typing-extensions"]
[project.urls]
Homepage = "https://blinker.readthedocs.io"
@@ -36,6 +37,27 @@ Chat = "https://discord.gg/pallets"
file = "README.rst"
content-type = "text/x-rst"
+[tool.mypy]
+python_version = "3.7"
+files = ["src/blinker"]
+show_error_codes = true
+pretty = true
+#strict = true
+allow_redefinition = true
+disallow_subclassing_any = true
+#disallow_untyped_calls = true
+#disallow_untyped_defs = true
+disallow_incomplete_defs = true
+no_implicit_optional = true
+local_partial_types = true
+no_implicit_reexport = true
+strict_equality = true
+warn_redundant_casts = true
+warn_unused_configs = true
+warn_unused_ignores = true
+warn_return_any = true
+#warn_unreachable = True
+
[tool.setuptools]
license-files = ["LICENSE.rst"]
include-package-data = false